[CLOSED] [1.0] Stores fail with error

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    [CLOSED] [1.0] Stores fail with error

    Since I updated to the newest SVN today I'm having issues with all my stores..
    Microsoft JScript runtime error: 'Ext.ux.data.PagingStore' is null or not an object

    It fails on this one example (taken from debug)

    Its a standard store, nothing special which I load in code behind.

    It's affecting all my stores.

    this.sActiveUsers=new Ext.ux.data.PagingStore({proxyId:"sActiveUsers",autoLoad:true,reader:new Ext.data.JsonReader({fields:[{name:"count"},{name:"dateActive"}]}),directEventConfig:{},proxy:new Ext.data.PagingMemoryProxy([{"count":"2","dateActive":"01-SEP"}], false)});
    
     <ext:ResourceManager ID="ResourceManager1" runat="server" Theme="Gray">
        </ext:ResourceManager>
     
          <ext:Store runat="server" ID="sActiveUsers">
                <Reader>
                    <ext:JsonReader>
                        <Fields>
                            <ext:RecordField Name="count"  ></ext:RecordField>
                            <ext:RecordField Name="dateActive" ></ext:RecordField>
                        </Fields>
                    </ext:JsonReader>
                </Reader>
            </ext:Store>
    Last edited by geoffrey.mcgill; Sep 02, 2010 at 3:44 PM. Reason: [CLOSED]
  2. #2
    Hi ljankowski,

    When I run your code everything appears to function properly. No JavaScript errors.

    Example

    <%@ Page Language="C#" %>
    
    <%@ Register Assembly="Ext.Net" Namespace="Ext.Net" TagPrefix="ext" %>
     
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" 
        "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
        
    <html xmlns="http://www.w3.org/1999/xhtml">
    
    <head runat="server"> 
        <title>Ext.NET Example</title> 
    </head> 
    <body> 
        <form runat="server"> 
            <ext:ResourceManager runat="server" /> 
      
            <ext:Store runat="server" ID="Store1">
                <Reader>
                    <ext:JsonReader>
                        <Fields>
                            <ext:RecordField Name="count" />
                            <ext:RecordField Name="dateActive" />
                        </Fields>
                    </ext:JsonReader>
                </Reader>
            </ext:Store>
        </form> 
    </body> 
    </html>
    Geoffrey McGill
    Founder & CEO
  3. #3
    Yeah I just looked at it again, I must have something else somewhere that's causing me to have an error, it's crashing my whole application now, I'll have to see if I can find it.

    Thanks
  4. #4
    This is odd I'm getting an error with the Extjs information

    ext.axd taken from firebug

    /*
    * @version   : 1.0.0 - Professional Edition (Ext.Net Professional License)
    * @author    : Ext.NET, LLC. http://www.ext.net/
    * @date      : 2010-06-15
    * @copyright : Copyright (c) 2006-2010, Ext.NET, LLC. (http://www.ext.net/). All rights reserved.
    * @license   : See license.txt and http://www.ext.net/license/. 
    * @website   : http://www.ext.net/
    */
    
    illegal XML character
    http://localhost:10546/extnet/extnet...xt.axd?v=26212
    Line 10
    
    <<<<<<< .mine
    where could that .mine be coming from? That's where it's crashing on my side

    I searched the code but I couldn't find it on my side

    /extnet/extnet-data-js/ext.axd Invalid XML Markup
    Last edited by geoffrey.mcgill; Sep 01, 2010 at 10:24 PM. Reason: please use [CODE] tags
  5. #5
    Hi,

    It seems was confilict during SVN update which you did not resolve
    I recommend to remove 'extnet-data.js' (in the Ext.Net\Build\Ext.Net\extnet\) file and update again
    Vladimir Shcheglov
    Sr. Developer
  6. #6
    Thanks I did download a fresh copy from SVN, but I'll make sure to do a complete cleanup and fresh download tonight to see if that fixes my problem.

Similar Threads

  1. Replies: 0
    Last Post: Jun 15, 2012, 9:06 AM
  2. Replies: 3
    Last Post: Feb 10, 2012, 12:50 PM
  3. [CLOSED] validation Fail
    By majestic in forum 1.x Legacy Premium Help
    Replies: 3
    Last Post: Oct 05, 2009, 4:36 AM
  4. ScriptManager in 2.0 app Causes CSS to fail
    By Tbaseflug in forum Bugs
    Replies: 0
    Last Post: Apr 22, 2009, 1:52 PM
  5. [CLOSED] validation fail
    By speedstepmem4 in forum 1.x Legacy Premium Help
    Replies: 2
    Last Post: Feb 12, 2009, 5:45 AM

Posting Permissions