[Bug] Broken Locale: Turkish

  1. #1

    [Bug] Broken Locale: Turkish


    Hello,

    It seems there are some problems with turkish locale. As an example Confirmation textbox is seen as

    "Evet" , "Hayır" as for "Yes" and "No". But this is incorrect. It should be

    "Evet", "Hayir". We don't have "ı" in turkish. If you use UTF-8 for your source code this problem shouldn't happen.

    Same problems apply to calendar as well.

    May as month is shown as Mayıs, but it should be Mayis.

    There are other mistakes as well. But mostly about lower I which is "i" without dot being shown as "ı"

    I am turkish and in case you need my help, let me know.

    You can check the turkish alphabet here

  2. #2

    RE: [Bug] Broken Locale: Turkish

    Hello,

    It
    seems there are some problems with turkish locale. As an example
    Confirmation textbox is seen as

    "Evet" , "Hayır" as for "Yes" and
    "No". But this is incorrect. It should be

    "Evet", "Hayir". We
    don't have "ı" in turkish. If you use UTF-8 for your source code this
    problem shouldn't happen.

    Same problems apply to calendar as
    well.

    May as month is shown as Mayıs, but it should be Mayis.

    There
    are other mistakes as well. But mostly about lower I which is "i"
    without dot being shown as "ı"

    I am turkish and in case you need
    my help, let me know.

    You can check the turkish alphabet here
  3. #3

    RE: [Bug] Broken Locale: Turkish


  4. #4

    RE: [Bug] Broken Locale: Turkish

    The last attachment I posted also covers "Passwords do not match" scenario as well
  5. #5

    RE: [Bug] Broken Locale: Turkish

    No one will reply to this bug ?
  6. #6

    RE: [Bug] Broken Locale: Turkish

    Hi,

    Thanks for your work. We will compare your attachment with ExtJS locale. I am sure that final 1.0 release will unclude correct locale.

    Thanks again
  7. #7

    RE: [Bug] Broken Locale: Turkish

    Thanks, make sure, you open the file and save it as UTF-8. That makes big difference.
  8. #8

    RE: [Bug] Broken Locale: Turkish

    Please use the last version I post. It also fixes Mayis (May)
  9. #9
    This issue still does exist in the RC build! I've sent the patch already please give it some love.
  10. #10
    Hi reverseblade,

    Thanks a lot for your feedback.

    I think the best way is fixing of source of this bug.
    The Ext.Net uses ExtJS localization scripts. The bug is there.

    Here is an example of reporting a localization's bug to the ExtJS's Bugs forum:
    http://www.sencha.com/forum/showthre...ay-names-spain

Similar Threads

  1. Turkish Character Problem
    By mikser in forum 2.x Help
    Replies: 0
    Last Post: May 04, 2012, 12:30 PM
  2. Locale
    By flaviodamaia in forum 1.x Help
    Replies: 0
    Last Post: Jul 08, 2010, 12:25 PM
  3. [CLOSED] Turkish special characters problem
    By tansu in forum 1.x Legacy Premium Help
    Replies: 6
    Last Post: May 26, 2009, 12:01 PM
  4. ??????????coolite?locale???? ??……
    By navy1020 in forum 1.x Help
    Replies: 10
    Last Post: May 05, 2009, 11:24 PM
  5. No ScriptManager1.Locale !
    By Nime in forum 1.x Help
    Replies: 1
    Last Post: Feb 04, 2009, 10:16 AM

Posting Permissions