[CLOSED] Setting the EmptyText property to a comboBox using local resources.

  1. #1

    [CLOSED] Setting the EmptyText property to a comboBox using local resources.

    Hi,

    I am using local resources to set the property EmptyText to a comboBox, but it does not work.

    Could you tell me please what I am doing wrong?

    <ext:ComboBoxid="comboBoxAvatarTopics"runat="server"StoreID="StoreAvatarTopics"DisplayField="TITLE" 
    ValueField="ID"Width="387px"Height="21px"LabelWidth="110"FieldLabel="Call Dr. Ned About " 
    Cls="comboBoxAvatarTopics"LabelAlign="Top"EmptyText="<%$ Resources: comboBoxAvatarTopics.EmptyText %>">
    Last edited by Daniil; Aug 05, 2010 at 2:04 PM.
  2. #2
    Hi,

    I ran a test based on your code sample and the .EmptyText property of the <ext:Combobox> appears to be set correctly when filled with a value keyed to a .resx file.
    Geoffrey McGill
    Founder & CEO
  3. #3
    Hi,

    You are right it gets the value from resx file, but when I used a different language it does not make the translation.

    Also I have the same problem with the proeperty Text in the ComboBox.

    For example I have the following resources for the page iNed:

    iNed.aspx.resx (it works fine for this resource)

    iNed.aspx.es.resx (it dos not work fine for this resource)

    I was trying to attach a zip (4 KB) with those files, but I got the following message:

    Sum of all attachments owned by flormariafr: 1.05 MB
    Current Attachment Total: 1.05 MB
  4. #4
    Does the same issue occur if you strip all the Ext.NET components out of the page, then set the .Text property of an <asp:TextBox> or <asp:Label>?
    Geoffrey McGill
    Founder & CEO
  5. #5
    Hi,

    No, I have not problem with asp.net controls and also I have not problem with ext:label.text.

    That problem only happen with the ext:ComboBox.
  6. #6
    Which version are you using?

    In the current build (v1.0), the EmptyText property is being set properly, although maybe in an earlier build there was a problem.
    Geoffrey McGill
    Founder & CEO
  7. #7
    Hi,

    I am using version 1.0
  8. #8
    Well, I'm out of ideas. For me the property is being set correctly.
    Geoffrey McGill
    Founder & CEO
  9. #9
    Hello, flormariafr!

    It works for me too...

    Please try to run the following sample code on your machine with the attached resource files and let us know the result.

    Example

    <%@ Page Language="C#" UICulture="es"%>
    
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head runat="server">
        <title>Ext.Net Example</title>
    </head>
    <body>
        <form runat="server">
        <ext:ResourceManager runat="server" />
        <ext:ComboBox runat="server" EmptyText="<%$ Resources: ComboBox.EmptyText %>"/>
        </form>
    </body>
    </html>

    I was trying to attach a zip (4 KB) with those files, but I got the following message:

    Please follow this link http://forums.ext.net/profile.php?do=editattachments
    Then tick some checkboxes on the right, then click on Delete Selected button at the bottom.

    After this things please try to attach your sample code again. We need all that can help to reproduce the issue. At least we need aspx and resx files.

    iNed.aspx.es.resx (it dos not work fine for this resource)
    Are you sure that the UICulture is "es" when you are testing the page? Please try to add the UICulture here:
    <%@ Page Language="C#" UICulture="es"%>

Similar Threads

  1. Replies: 0
    Last Post: Apr 02, 2010, 8:06 PM
  2. Replies: 6
    Last Post: Feb 11, 2010, 3:45 PM
  3. [CLOSED] I got errors after generating Local resources files
    By flormariafr in forum 1.x Premium Help
    Replies: 2
    Last Post: Feb 11, 2010, 1:46 PM
  4. Replies: 0
    Last Post: Aug 05, 2009, 10:48 AM
  5. Replies: 1
    Last Post: Jul 29, 2009, 4:13 PM

Posting Permissions