ComboBox won't work with .net 2.0

  1. #1

    ComboBox won't work with .net 2.0

    <H2>Could not load file or assembly 'System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified.

    Stack Trace:

    <TABLE width="100%" bgColor=#ffffcc>
    <TBODY>
    <TR>
    <TD><CODE>[FileNotFoundException: Could not load file or assembly 'System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified.]
    Newtonsoft.Json.JsonSerializer.Serialize(JsonWrite r jsonWriter, Object value) +0
    Coolite.Ext.Web.JSON.Serialize(Object obj, List`1 converters) +286
    Coolite.Ext.Web.Store.OnBeforeClientInit(Observabl e sender) +147
    Coolite.Ext.Web.Observable.OnBeforeClientInitHandl er() +20
    Coolite.Ext.Web.Observable.OnClientInit() +12
    Coolite.Ext.Web.WebControl.SetResources() +77
    Coolite.Ext.Web.WebControl.OnPreRender(EventArgs e) +371
    Coolite.Ext.Web.StoreDataBound.OnPreRender(EventAr gs e) +40
    System.Web.UI.Control.PreRenderRecursiveInternal() +86
    System.Web.UI.Control.PreRenderRecursiveInternal() +170
    System.Web.UI.Control.PreRenderRecursiveInternal() +170
    System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2041
    </PRE></CODE></TD></TR></TBODY></TABLE></H2>
    When I try to use the ComboBox control on my page I get the following error... It's strange though, because all of the other ext controls I've used so far have worked. I have .net 2.0 installed... from what I understand from the error message, it looks like a JSON component is looking for .net v3.5? Is there any way I can fix this? Here is what the line of interest looks like in my web.config file, you can see that the correct version, 2.0.0.0 is specified, but the error above is looking for v3.5:




    <add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>


    Thanks!
  2. #2

    RE: ComboBox won't work with .net 2.0

    Hi msnyder0,

    The following forum thread discusses the .NET 3.5 System.Core.dll requirement, seehttp://forums.ext.net/showthread.php...1765-16-1.aspx


    Hope this helps.


    Geoffrey McGill
    Founder

Similar Threads

  1. [CLOSED] PageSize property of ComboBox control does not work
    By T3rryChan in forum 2.x Legacy Premium Help
    Replies: 2
    Last Post: Jun 15, 2012, 7:37 PM
  2. [CLOSED] Linked Combobox can't work
    By gs_user in forum 2.x Legacy Premium Help
    Replies: 2
    Last Post: May 02, 2012, 7:26 AM
  3. [CLOSED] Doesn't work ToolTips for ComboBox Items
    By ViDom in forum 1.x Legacy Premium Help
    Replies: 4
    Last Post: Nov 15, 2011, 3:30 PM
  4. Two binding combobox not work by items way
    By animalisme in forum 1.x Help
    Replies: 1
    Last Post: Sep 28, 2009, 3:30 AM
  5. [CLOSED] Problem making ComboBox Search work
    By pkellner in forum 1.x Legacy Premium Help
    Replies: 5
    Last Post: Nov 25, 2008, 1:52 PM

Posting Permissions