[CLOSED] Panel property AuthoHeight="true" does not work loading pages with long content.

  1. #1

    [CLOSED] Panel property AuthoHeight="true" does not work loading pages with long content.

    Hi,

    I am using a panel to load some pages that have long content like for example a blog that has to be adjusted when the user add the comments.

    I setted the property AuthoHeight="true", but it does not work.

    protected void Page_Load(object sender, EventArgs e)
    {
        if (!X.IsAjaxRequest)
        {
            PanelContent.AutoLoad.Url = this.ResolveUrl(@"~\ManagePortal.aspx");
            PanelContent.AutoLoad.Mode = Ext.Net.LoadMode.IFrame;
            PanelContent.AutoLoad.NoCache = true;
        }
    }
    
    <ext:Panel 
        ID="PanelContent"
        runat="server"
        AutoHeight="true"
        AutoWidth="true"
        Border="false">
        <Content>
        </Content>
    </ext:Panel>
  2. #2

    RE: [CLOSED] Panel property AuthoHeight="true" does not work loading pages with long content.

    Hi,

    Iframe cannot automatically resize by own content. Therefore AutoHeight has no sense. You can try iframe tag and approaches from the following links
    http://www.frontpagewebmaster.com/m-89000/tm.htm
    http://geekswithblogs.net/rashid/arc...13/103518.aspx
  3. #3

    RE: [CLOSED] Panel property AuthoHeight="true" does not work loading pages with long content.

    Actually if you are just looking to have everything in your IFrame resize to the size of your autoload panel put everything in your IFrame into a viewport > Borderlayout > center

    It seems to work great for me and will resize with your browser window, however I am having an issue with the one panel leaving the bottom border line off until I resize the browser the first time. I have to first see if this is an IE issue or if it's just something else...


    Update: This way will allow you content to scroll in the panel if your blog data is larger then the panel size.


    The border issue seems to be an IE issue, I don't have the same problem with Firefox or Mac clients.

Similar Threads

  1. [CLOSED] Loading data in store take too long. browser hangs.
    By speedstepmem3 in forum 1.x Legacy Premium Help
    Replies: 21
    Last Post: Nov 22, 2011, 9:42 AM
  2. Replies: 4
    Last Post: Nov 03, 2011, 7:46 PM
  3. Tab Panel Content Loading
    By xMAC in forum 1.x Help
    Replies: 5
    Last Post: Dec 10, 2010, 8:07 AM
  4. [CLOSED] AutoHeight="true" does not work for a panel that load a page
    By flormariafr in forum 1.x Legacy Premium Help
    Replies: 5
    Last Post: Feb 25, 2010, 6:13 PM
  5. Dynamic loading content page into Panel
    By wildspirit in forum 1.x Help
    Replies: 2
    Last Post: Feb 04, 2009, 6:59 PM

Posting Permissions