The word "reading" appears during component refresh

  1. #1

    The word "reading" appears during component refresh

    书写Demo示例的时候,发现 在组件GridPanel加载数据过程中出现“ 取中”三个字是繁体的,而页面并没 繁体的出现,经过跟踪发现是来自ext .net.dll内部的ext-lang-zh_CN.js中查询到这三个繁体字,如何解 决


    Translated (Google)

    "Reading" appears in the process of refreshing the component is a traditional word
    When writing the demo example, it was found that the three characters "� �取中" appeared in the process of loading data in the component GridPanel were in traditional Chinese, but the page did not appear in traditional Chinese. After tracking, it was found that it came from ext.net.dll. How to solve these three traditional characters in ext-lang-zh_CN.js
    Last edited by geoffrey.mcgill; Nov 27, 2020 at 5:54 AM.
  2. #2
    Hello @faith, and welcome to Ext.NET Forums!

    Unfortunately we are not able to reliably provide support in Chinese, so I need to rely on google translation for this one.

    I have checked online examples and our source code and I could find the part you pointed with the (hopefully) right character instead of the two unknown marks you pasted.

    I see the text is related to "loading" messages, like loadingText: "讀取中 ...". As you can see, the first character, 讀, is printed as this, not these untranslatable character byte characters (question mark within diamond-shaped square). I looked up both debug and release version, simplified (zh-CN) and traditional (zh-TW), and wherever I find "取中" they come preceded by "讀", which looks right to me.

    There may be something wrong with the host charset encoding (your IIS server configuration, something). I'm not sure you're able to continue this discussion in English, but it would help to know the environment you reproduced this (production/IIS, development/IIS express/Visual Studio), and whether you tried that with latest Ext.NET version.

    I have also checked this on Ext.NET 4 and I couldn't find the wrong character. Please check this example on Ext.NET 4. Switch to the Chinese language and watch the loaded resources. At my end, I get a minified file with the correct word.

    In that same example, you can check the visual effect if you open the example (direct) or switch console to it and App.ComboBox1.setLoading(). It should display a loading mask over the combo box component with that sequence of characters.

    Overall it still looks like a charset issue either on your web server or your web browser. If that's in the web browser, this may be a problem as customers may all be affected by the issue; and if that's the case, we'd need to learn how to reproduce it on our end before we can further help you with.

    Hope this helps!
    Fabrício Murta
    Developer & Support Expert

Similar Threads

  1. [CLOSED] Combobox Component Column not displayed after store refresh / reload
    By Digital.Dynamics in forum 2.x Legacy Premium Help
    Replies: 2
    Last Post: Nov 15, 2017, 2:50 PM
  2. Use a Word document
    By Coroner in forum 1.x Help
    Replies: 1
    Last Post: Jun 28, 2012, 10:33 PM
  3. [CLOSED] Menu Component appears under menu
    By imaa in forum 1.x Legacy Premium Help
    Replies: 1
    Last Post: Sep 08, 2011, 12:34 PM
  4. copy paste from ms word
    By [WP]joju in forum 1.x Help
    Replies: 0
    Last Post: Aug 20, 2010, 8:30 AM
  5. Any word on MVC sample?
    By UGRev in forum Open Discussions
    Replies: 14
    Last Post: Apr 06, 2009, 5:24 PM

Tags for this Thread

Posting Permissions