Links to ExtNet resources not being generated correctly when running the site in a subdirectory in IIS

  1. #1

    Links to ExtNet resources not being generated correctly when running the site in a subdirectory in IIS

    I've created a sample website using the 'Ext.NET Classic Mvc Application' project template. When I run this website using Development-Time IIS debugging support, links to the core ExtNET scripts are not resolved relative to the application virtual root path. Instead, they are resolved relative to the website root path. My website is running at the location http://localhost/extnetcoresample, so I would expect links to the core ExtNET scripts to be generated as http://localhost/extnetcoresample/extnet/. Instead, they are being generated as http://localhost/extnet/ which isn't resolvable. I would have expected the Ext.NET framework to be able to automatically take account of the application virtual root path when generating these links, as it did with the legacy .NET Framework versions of the product. I did try setting the base path in my Startup.cs file by adding a call to
    app.UsePathBase("/ExtNetCoreSample");
    in the
    Configure(IApplicationBuilder app, IWebHostEnvironment env)
    method, but this didn't have any effect. Please can you advise whether this is a bug, or if there is something else I need to do when running a website from a subfolder?
  2. #2
    I believe the following thread should help, see

    https://forums.ext.net/showthread.ph...plication-name
    Geoffrey McGill
    Founder
  3. #3
    Geoffrey

    Thanks, I was able to get things working by setting the RequestRoot property as per the other post. I'll await the next release where this is fixed.

    Regards

    Paul
    Last edited by geoffrey.mcgill; Nov 03, 2020 at 3:39 PM.

Similar Threads

  1. [OPEN] [#356] Gzipped extnet static resources not persistanced
    By michaeld in forum 2.x Legacy Premium Help
    Replies: 11
    Last Post: Oct 15, 2013, 12:55 PM
  2. Replies: 3
    Last Post: Feb 06, 2013, 4:33 PM
  3. [CLOSED] DirectEvent.Click.Url path on nested site at IIS
    By mcfromero in forum 1.x Legacy Premium Help
    Replies: 1
    Last Post: Jan 03, 2013, 7:39 PM
  4. [CLOSED] bypassing authentication for EXTJS EXTNET resources
    By webclouder in forum 1.x Legacy Premium Help
    Replies: 1
    Last Post: Apr 22, 2011, 3:57 PM
  5. [CLOSED] IIS 6.0 Coolite web.config Setup - Cannot Find .axd Resources
    By iansriley in forum 1.x Legacy Premium Help
    Replies: 2
    Last Post: Oct 21, 2010, 4:51 PM

Posting Permissions