[FIXED] [#1633] [4.8.1] Upgraded from 4.7 to 4.8. The grids no longer shows data.

  1. #1

    [FIXED] [#1633] [4.8.1] Upgraded from 4.7 to 4.8. The grids no longer shows data.

    Strange, the paging toolbar says "Displaying 1 - 3 of 3".

    Checking the HTML, all the rows are empty.

    Is it a known issue?
    Last edited by fabricio.murta; Feb 28, 2019 at 1:59 AM.
  2. #2
    I found that this is causing it:

    .SelectionModel(Html.X().CheckboxSelectionModel())


    Removing this line, and all data shows. So it has to do with the CheckboxSelectionModel.
  3. #3
  4. #4
    Hello @sveins12!

    Thanks for reporting the issue, we've logged it under #1633 on github. Interesting this one leaves no exception whatsoever, just silently stops rendering the grid rows.

    We'll post an update here as soon as we get the issue fixed!
    Fabrício Murta
    Developer & Support Expert
  5. #5
    There is a warning though, I don't know if it has to do with the issue:

    [W] XTemplate evaluation exception: Cannot read property '$className' of undefined
  6. #6
    Hello again @sveins12!

    Quote Originally Posted by sveins12
    There is a warning though, I don't know if it has to do with the issue
    That was indeed a good lead and was emitted exactly because of the issue, thanks for sharing! At first I didn't see it, as I checked on release-mode example (which these warnings are suppressed).
    Fabrício Murta
    Developer & Support Expert
  7. #7
    Hello once again @sveins12!

    We've just not only fixed the issue, but also released Ext.NET 4.8.1 with the fix publicly available! Thanks again for the report!
    Fabrício Murta
    Developer & Support Expert
  8. #8
    It's working! :)

    Thank you for the very fast response and fix!

Similar Threads

  1. Replies: 9
    Last Post: Jun 08, 2017, 9:24 PM
  2. Filtering Data between grids
    By Anburaja in forum 1.x Help
    Replies: 0
    Last Post: Nov 09, 2012, 9:33 AM
  3. Replies: 2
    Last Post: Mar 04, 2011, 2:16 PM
  4. grdpanel does not shows the binding data
    By Dinesh.T in forum 1.x Help
    Replies: 1
    Last Post: Mar 26, 2010, 6:31 AM
  5. [FIXED] [V0.6] .FindControl no longer required
    By geoffrey.mcgill in forum Bugs
    Replies: 0
    Last Post: Feb 12, 2008, 7:49 PM

Posting Permissions