[CLOSED] Google Chrome and HTTPS

  1. #1

    [CLOSED] Google Chrome and HTTPS

    Hello Support,

    we have a problem with an existing ext.net web application. Some elements are not shown when working in Google Chrome (latest version) and https protocol. When switching to http the problem does not exist anymore.

    Can you help us with that or what information do we need to provide to get this bug fixed.

  2. #2
    Hello @moldaschl, and welcome to Ext.NET!

    Ext.NET is in a layer independent on the HTTP transport to the website, so there's not much it can do to either cause or mitigate issues with HTTPS/SSL.

    You probably have hardcoded absolute URLs within your HTTPS website which still points to HTTP endpoints. You should inspect your page sources to see where those references are being emitted and fix those cases.

    For example if you try http://examples4.ext.net/ and https://examples4.ext.net/ you'll see both will work without issues, and they are but the very same web application. So long as you don't leave absolute, http:// references throughout your website, you should have absolutely no issues on the HTTP transport while using Ext.NET. It always creates dynamic script includes based on the active HTTP transport used to initially open the page.

    Hope this helps!
    Fabrício Murta
    Developer & Support Expert
  3. #3
    Hello Fabricio,

    Many thanks for your response!
    You can see in the attachments that there are no references to HTTP://.
    html_source.txtClick image for larger version. 

Name:	fiddler_traffic_01.jpg 
Views:	4 
Size:	103.5 KB 
ID:	25183Click image for larger version. 

Name:	fiddler_traffic_02.jpg 
Views:	4 
Size:	101.6 KB 
ID:	25184

    Another info:
    The web application has already worked with HTTPS in the Google Chrome browser.
    We have not changed anything in the web application, and yet it has not been working in the Google Chrome browser for some time. From which version I can not say unfortunately.

    Greetings from Berlin,
  4. #4
    Hello, that's really odd.

    So you are saying it does not show some of the content. Yet, you don't get any browser warning on console or anything?

    Google Chrome often makes updates that just break it for cases it used to work a long time, that's really unfortunate, but most times there are ways to go around the problem and make it work.

    Nevertheless, one important step would be to identify what exactly is the issue preventing the page to work.

    Are you able to reproduce the issue if you just publish a simple Ext.NET page on your website? We would require the minimal scenario necessary to reproduce the issue before we can further understand this and help you.

    I suggest you to draw a simple Ext.NET page, maybe based on an example at our examples explorers. Maybe with little modification in a simplified example you can reproduce the issue and share that code here so we can reproduce it on our side and pinpoint the cause, suggest you a workaround for the time being and log as a bug (and fix) as it fits.

    We also have some old, Ext.NET 2.x, threads where issues related to Ext.NET and SSL have been fixed.The problem is that as per your report, there's no warning/error message in the browser while loading the page, what was the cause back then.

    You may want to review this forum thread to check whether your problem is possibly a regression of the one discussed in this thread: HTTPS issues with non https content. Here, it was discussed the issue caused by some CSS files referencing non-https endpoints in given circumstances, but were fixed back in the v2 release still.

    In the end, as I said in the previous post, the Ext.NET examples runs over SSL connection and everything is showing up just fine, so we would need to know what component or setting you add to your page so that it breaks once run over SSL.

    Please understand we do not want your proprietary code, by the contrary, we need a simple test case, preferably based on one from examples explorer, just to illustrate the scenario required to reproduce the issue. Then we could step-in the page loading process and identify the actual cause.

    Here's another suggestion, if feasible: you could just clone the whole Ext.NET Examples repository and publish it to your HTTPS website; then check if it works, or where it breaks. But that would basically only help by ensuring whether it is a project setting or IIS setting that could be affecting the website behavior over SSL.

    Sorry for the long reply, tried to be the most complete and clear the possible while the provided information at this point still does not shed a light on the actual problem and possible solution.

    While we are at the long read, I'd suggest you reviewing our guidelines on posting threads, there are useful tips on making simplified test cases, if this scenario can be reproduced in simple cases:

    - Tips for creating simplified code samples
    - More Information Required
    - Forum Guidelines

    Hope this helps!
    Fabrício Murta
    Developer & Support Expert
  5. #5
    Hello Fabi,

    Thanks for your answer in detail.

    As far as we can say is that the described examples will work on the server with SSL active. This is because other Ext.NET applications work well also in the same environment. It is about this specific application where we cannot determine the problem. Could it be a way to give you direct access and let you have a look at the server. Of course the credentials cannot be published in the forum but later on maybe the solution.

  6. #6
    Hello @moldashi!

    Unfortunately, we can't offer server-specific help, and private/proprietary information shouldn't be shared here at the forums. If you can reproduce the issue in a simplified and reproducible scenario, then we could identify the issue. But full implementations can have a range of issues not related to Ext.NET, that would require learning your infrastructure and technologies, which goes beyond the scope of Ext.NET.

    Hope you understand. If you can isolate the issue down to Ext.NET, we would be glad to help you sort that out.

    Regardless of that, this thread is open and hopefully, somebody in the community who possibly experienced this in the past could help with the solution they found.

    EDIT: If you can't reproduce the issue with Ext.NET examples it likely means the problem is really not coming from Ext.NET, so you should take a closer look to other aspects of the application before assuming that's an issue with Ext.NET. It could be just a way you check the protocol while providing responses or something like that. You could use the browser's developer tools and network monitor to identify what's making the offending transaction that's tainting your SSL connection. Nevertheless, simplifying the page you are working on until you see the error change/vanish should be a way to identify where exactly the issue is.
    Last edited by fabricio.murta; Sep 20, 2018 at 5:32 PM.
  7. #7

    Warning s.gif

    Hey again :-)

    We are guessing that this warning from the screenshot attached that has it’s origin in ext.axd has something to to with our problem. Could it might be that because of this all cklicks in the menu, tree entry etc. do not work?

    Click image for larger version. 

Name:	24-09-2018 19-12-47.png 
Views:	6 
Size:	30.6 KB 
ID:	25185
  8. #8
    Hello, @moldaschi!

    Thanks for coming back to us. I'm not really sure how that address is coming back from Ext.NET -- not directly at least. If you click that underlined address showing Ext.axd, you might see the exact context that comes from. Ext.NET resources should only be pointing to urls in resources files, which URLs would also contain ext.axd? in its path.

    In the case it is just looking for ./Resources/Images/s.gif. Ext.NET has some embedded resources called s.gif, but they are into subdirectories for tree or desktop. So, that could be coming from Ext.NET, yes, but instructed from somewhere within the website code, not likely Ext.NET.

    Besides, as I can see by the warning, it is pointing to the same https:// address as well. The issue in that may not be affecting SSL at all, but related to a way a call (like form submit) is made, where it should be done via ajax.

    I found some related warning reports in Ext JS (underlying framework to Ext.NET), and it turned out it was the way forms were submitted, so you should look that up. But this can be with any form you potentially submit or any request you make from the website, so it is still hard to say that's inherent from Ext.NET from just the screenshot you shared. It could, and could not. I found this generic case in stack overflow: Resource interpreted as Document but transferred with MIME type application/zip

    No matter what, it still does not look like that warning would trigger SSL issues on the page. It should also trigger if you run the non-ssl version -- given the page served to the browser is the exact same.

    If you find a consistent way to reproduce this warning in a simplified Ext.NET test case, I'm sure we'd be able to give you further light on the matter.

    I hope the explanations above clarify, and potentially help you in some way getting the source of the issue you are facing with your website.

    EDIT: I've mistakenly written about 2.gif where the right name was clearly s.gif, and I rectified the second paragraph above to reflect the actual info.
    Last edited by fabricio.murta; Sep 25, 2018 at 4:18 PM.
  9. #9
    Looks like the issue occurred in some custom JavaScript being executed within the clients' app. The user @moldaschi will provide an update.

    Closing this issue, although will re-open in the future if Ext.NET is determined to be the source of the problem.
    Geoffrey McGill
    Founder & CEO

Similar Threads

  1. [CLOSED] Problem with Google Chrome.
    By farisqadadeh in forum 1.x Premium Help
    Replies: 30
    Last Post: Jan 02, 2011, 6:10 PM
  2. [CLOSED] Tab Panel Not Rendering In Google Chrome
    By garrisrd in forum 1.x Premium Help
    Replies: 2
    Last Post: Aug 11, 2010, 8:23 AM
  3. google chrome help
    By [WP]joju in forum 1.x Help
    Replies: 0
    Last Post: Oct 02, 2009, 4:27 AM
  4. Google Chrome ignores key mapping?
    By dbassett74 in forum 1.x Help
    Replies: 0
    Last Post: May 29, 2009, 6:56 PM
  5. Google Chrome ComboBox Render
    By davidhoyt in forum Bugs
    Replies: 3
    Last Post: Dec 18, 2008, 9:48 PM

Posting Permissions