The official release of Ext.NET Mobile is now available. Ext.NET Mobile is an ASP.NET component framework for building Phone and Tablet specific mobile web applications. Read More

[FIXED] [#1564] [4.2.0 Mobile] Doesnt load in Oreo and/or pixel

Page 2 of 2 FirstFirst 12
  1. #11
    I tried twice.
    I rolled back to 4.1.0 and it works fine.
    I can show u via WebEx if u want.

    Also, we just change version via nuget for project.

    We use VSTS to do our builds and it gets all libraries via nuget during build.
    /Z
  2. #12
    Hello, @Z!

    I'm not sure how you can show it with WebEx. Is that a video stream service? I guess as long as you don't share your proprietary/private info with the video it would be alright as a sample on how to reproduce the issue you're facing.


    Notwithstanding, I've done the following test, and it worked just nice:
    1. Create new Project
    2. Install NuGet for Ext.NET Mobile 4.1.0 (previous release)
    3. Build & run the default/test page that comes with the package installation (Ext.NET.Mobile.Default.aspx)
    4. Upgrade the NuGet package from 4.1.0 to 4.1.1 (current release)
    5. Repeat step 3.

    All working. Checked client-side loaded page after upgrade, and it correctly reflects the version change (Ext.net.Version shows 4.1.1).

    The issue you're having may be related to your recurring issues with upgrading Ext.NET, it would be nice if we knew exactly why that was but it could be something very specific to your project set up, really difficult to guess.
    Fabrício Murta
    Developer & Support Expert
  3. #13
    My mobile app is a separate brand new project.
    I update via nuget and then check in packages file.

    My.websites.com is fake since that was my relationship site.

    It cant find /extnet/extnet-init-js/ext-mobile.axd

    Is extnet-init-js new??

    Also, if I replace init with all, I can see version as 4.1.1

    Tested chrome and Firefox. Spent hours on it....

    /Z
  4. #14
    Hi @Z!

    Sorry for all the trouble.

    The /extnet/extnet-init-js/ext-mobile.axd path is the dynamic Ext.NET script, a translation from your actual aspx/cshtml file to the equivalent ExtJS client-side code, so it is unique, lasts the life of the ASP.NET page load, and depends on the key you see in you browser debugging tools' network monitor during page load.

    This is not a new feature, it's been around since Ext.NET 2, but you can disable it and have the contents that would go to that dynamic URL merged into your page's output.

    Just set InitScriptMode to Inline either in your Ext.Net.Mobile.ResourceManager definition, or Web.config's extnet tag. Then your (say) Default.aspx file will have a tag like this when you check sources from web browser's debugging tools:

        <script type="text/javascript">
        //<![CDATA[
            Ext.net.ResourceMgr.init({id:"ctl01",theme:"triton",icons:["Accept"],locale:"en-US"});Ext.onReady(function(){Ext.create("Ext.net.Viewport",{padding:10,items:[{xtype:"container",contentEl:"ctl04_Content"},{id:"TextArea1",height:85,xtype:"textareafield",margin:"10 0 5 0",label:"Message",labelWidth:80,placeHolder:">> Enter a Test Message Here <<"},{id:"Button1",xtype:"button",iconCls:"#Accept",text:"Submit",directEvents:{tap:{fn:function(item,e){Ext.net.directRequest({extraParams:{"text":App.TextArea1.getValue()},eventMask:{xtype:"loadmask"},control:this,action:'Tap'});}}}}],layout:"vbox"});});
        //]]>
        </script>
    You can improve the formatting of this output (regardless of using Inline or Linked in your InitScriptMode) by setting SourceFormatting to true.

    But, if the extnet-init-js path works for 4.1.0, it should work for 4.1.1.

    The only reason I can see this stops working when you upgrade Ext.NET, would be something on your system preventing the 4.1.1 Ext.NET DLL to be linked to the project. You may look that up in your project's references, check if the Ext.NET reference has a small yellow exclamation, in solution explorer, when you expand the References folder (one of the first expandable entries in your project's tree).

    I hope this helps!
    Fabrício Murta
    Developer & Support Expert
  5. #15
    ok. I just cant spend any more time on this. it is just NOT working.

    removed the ext.net MVC mobile and then regot it from nuget. look at what I see!!!!

    I will send you a skype address via email. please reach out to me tomorrow. I really need to get this resolved.

    /Z
    Attached Thumbnails Untitled.png  
  6. #16
    Hello @Z!

    Just checked here and yes, I have this same here from the project I built first with 4.1.0 then upgraded to 4.1.1.

    But it works nevertheless. And updated. If I browse to the project's bin folder and check windows properties on Ext.Net.Mobile.dll, this is what I get:

    Click image for larger version. 

Name:	62143-fileProps.png 
Views:	1 
Size:	12.0 KB 
ID:	25064

    Looks right from here, don't you agree? Can you check that on your side, if your DLL file reflects the right version when you update it?

    Not happy with the result so far, there's no point if when I run the page, client-side, the thing is still 4.1.0. So I run that very project, open console and, look:

    Click image for larger version. 

Name:	62143-clientSideVer.png 
Views:	2 
Size:	22.5 KB 
ID:	25065

    So, it reports the right version. Moreover, I did dig thru the returned JavaScript sources and I found the fix exactly as it were. Also tested the page faking the Android 8 user-agent string that broke it. That's really really strange it does not run on your side at all.

    If you open your project's .csproj file for editing (in a text editor), you'd find this within:

    <Reference Include="Ext.Net.Mobile, Version=4.1.0.0, Culture=neutral, PublicKeyToken=1ac231f0ab990856, processorArchitecture=MSIL">
      <HintPath>..\packages\Ext.NET.Mobile.4.1.1\lib\net45\Ext.Net.Mobile.dll</HintPath>
    </Reference>
    You should see how it points towards 4.1.0.0 there, yet the path to the NuGet package suggests it points towards version 4.1.1.

    I'm sure you already tried this a dozen of times but, who knows... What about a clean + build (rebuild) of the project, after upgrading the NuGet package? Uninstalling and reinstalling the package also may help. Here, I have just run NuGet's upgrade process and it worked like a charm.
    Fabrício Murta
    Developer & Support Expert
  7. #17
    It works fine locally. It FAILs when VSTS builds and deploys it.
    I can only retest this (and check client side version) late nights since it brings down our production app.
    /Z
  8. #18
    Hi @Z!

    Double check your server's Web.config file for the include line with Ext.NET DLL. The key might have changed.

    Anyway, you are right, and the version has a problem. And this may be the reason it works locally but not when you publish.

    We'll check if it is possible to rewrite the NuGet package for 4.1.1 (which is broken), or release 4.1.2 double checking this specific issue.
    Fabrício Murta
    Developer & Support Expert
  9. #19
    ok. Let me know when it is fixed and I will retry. I also set Inline so that may help.
    /Z
  10. #20
    Setting InitScriptModr to Inline fixed it.

    Pls do fix the nuget version
    /z
Page 2 of 2 FirstFirst 12

Similar Threads

  1. Replies: 4
    Last Post: Oct 16, 2017, 4:18 PM
  2. Replies: 9
    Last Post: Jan 14, 2017, 8:35 PM
  3. Replies: 1
    Last Post: Aug 17, 2015, 10:36 AM
  4. Replies: 1
    Last Post: Apr 25, 2015, 10:31 AM
  5. Replies: 4
    Last Post: Aug 30, 2011, 10:35 PM

Posting Permissions