[CLOSED] [#1154] Chrome saving login/password

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    [CLOSED] [#1154] Chrome saving login/password

    in v1.7, Chrome would prompt to save the password on login and then it would save it for future use. in v3.2.1, it doesn't. it is as if the password field isnt properly registered with the browser.
    Thanks,
    /Z


    <%@ Page Language="C#" %>
    
    
    <%@ Register Assembly="Ext.Net" Namespace="Ext.Net" TagPrefix="ext" %>
    
    
    <!DOCTYPE html>
    
    
    <html>
    <head id="Head1" runat="server">
        <title>Ext.NET v3.2.1 Example</title>
    </head>
    <body>
        <form id="Form1" runat="server">
            <ext:ResourceManager ID="ResourceManager1" runat="server" />
                <ext:Container runat="server" Layout="FormLayout">
                    <Items>
    
    
                   <ext:FormPanel 
                        runat="server" 
                        ID="loginForm"
                       Width="400"
                        Border="false"
                        BodyStyle="background:transparent;" >
                        <Items>
                            <ext:TextField 
                                ID="user" 
                                runat="server" 
                                FieldLabel="Username" 
                                AllowBlank="false"
                                BlankText="Username is required."
                                Text=""
                                AutoFocus="true"
                                AutoFocusDelay="100"
                                >
                                </ext:TextField>
                             <ext:TextField 
                                ID="txtPassword" 
                                runat="server" 
                                InputType="Password" 
                                FieldLabel="Password" 
                                AllowBlank="false" 
                                BlankText="Password is required."
                                Text=""
                                />
                        </Items>
                        <Buttons>
                            <ext:Button ID="test44" runat="server" Text="Login" Icon="Accept">
                                <DirectEvents>
                                    <Click 
                                        Url="/ta/yyy/test/" 
                                        Timeout="60000"
                                        FormID="loginForm"
                                        CleanRequest="true" 
                                        Method="POST">
                                        <EventMask MinDelay="250" />
                                    </Click>
                                </DirectEvents>
                            </ext:Button>
                        </Buttons>
                    </ext:FormPanel>
                    </Items>
                </ext:Container>
      
        </form>
    </body>
    </html>
    Last edited by Daniil; Dec 25, 2015 at 1:04 PM. Reason: [CLOSED] [#1154]
  2. #2
    Hi @Z,

    As far as I can know saving password functionality requires a hard PostBack.
    http://forums.ext.net/showthread.php...l=1#post117568

    Please try this Button. Chrome suggests to save a password with this Button.
    <Buttons>
        <ext:Button 
            runat="server" 
            Text="Login" 
            Icon="Accept" 
            AutoPostBack="true" />
    </Buttons>
    It might also need to turn "autocomplete" on:
    http://forums.ext.net/showthread.php...l=1#post124336
  3. #3
    need MVC and this worked fine in 1.7.
    /Z
  4. #4
    this worked fine in 1.7
    This exact sample? I tried to run it in 1.7. It runs well, but Chrome doesn't suggest to save a password. Could you, please, provide a working v1.7 sample? Just as a start point for my investigation.
  5. #5
    yes. The only difference is that we used a Window in PROD instead of a Container.
    /Z
  6. #6
    Repeat myself, I could not get your sample working with 1.7. Same with a Window instead of a Container. Does it work for you?

    I quite need a working v1 sample. Then I could investigate why it stopped working in v3. I don't really an expert of that "save password" functionality and I cannot say what is going wrong without investigating in details. A working v1 test case would help me a lot and I would be able to help sooner.

Similar Threads

  1. [CLOSED] Password fields TextField saves the password
    By ucaneto in forum 2.x Premium Help
    Replies: 1
    Last Post: Oct 29, 2014, 4:38 PM
  2. Replies: 9
    Last Post: Jul 25, 2012, 3:19 PM
  3. Replies: 0
    Last Post: Feb 23, 2012, 7:18 AM
  4. Implement a Password Meter to a Password Field
    By sudantha in forum 1.x Help
    Replies: 1
    Last Post: Jan 15, 2012, 7:59 AM
  5. login problem with Ext Login Control
    By Bruce2010 in forum 1.x Help
    Replies: 1
    Last Post: Nov 30, 2010, 5:35 PM

Tags for this Thread

Posting Permissions