[CLOSED] Html editor is not working properly.

  1. #1

    [CLOSED] Html editor is not working properly.

    Hi,

    <%@ Page Language="C#" %>
     
    <!DOCTYPE html>
     
    <script runat="server">
     
    </script>
     
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head runat="server">
        <title></title>
    </head>
    <body>
        <form id="form1" runat="server">
            <div>
                <ext:ResourceManager ID="ScriptManager1" runat="server" Namespace="Sample"></ext:ResourceManager>
                <ext:Viewport runat="server" Layout="FitLayout">
                    <Content>
                        <ext:Container runat="server" Layout="BorderLayout">
                            <Content>
                                <ext:Panel runat="server" ID="Panel1" Height="200" Region="North">
                                    <Items>                                    
                                        <ext:HtmlEditor runat="server" Width="800"></ext:HtmlEditor>
                                    </Items>
                                </ext:Panel>
                            </Content>
                        </ext:Container>
                    </Content>
                </ext:Viewport>
            </div>
        </form>    
    </body>
    </html>
    Steps to reproduce:
    Type something inside the html editor and press ENTER


    The first line that we typed comes down and also an empty line is inserted after this line.

    Please guide us to make the alignment properly in an HTML editor.

    Note: Refer the attached screenshot.
    Attached Thumbnails Click image for larger version. 

Name:	Html.jpg 
Views:	15 
Size:	37.9 KB 
ID:	15391  
    Last edited by Daniil; Oct 07, 2014 at 5:43 AM. Reason: [CLOSED]
  2. #2
    Hi

    HtmlEditor depends from browser because it is just element is marked as contenteditable="on" (https://developer.mozilla.org/en-US/...ntent_Editable)
    So, the html editor behaviour is totally under browser control, we cannot change that behaviour

    I guess that your browser wrap line by <p> tag therefore you see that empty lines. You can try to press Shift+Enter instead Enter to prevent it but as I say the behaviour is totally under browser control therefore it can be different in different browsers
    Vladimir Shcheglov
    Sr. Developer

Similar Threads

  1. [CLOSED] Layout Fit not working properly
    By Z in forum 1.x Legacy Premium Help
    Replies: 4
    Last Post: Aug 27, 2013, 11:17 PM
  2. Replies: 9
    Last Post: Oct 08, 2012, 7:49 AM
  3. Replies: 0
    Last Post: Jun 22, 2012, 10:17 AM
  4. Replies: 3
    Last Post: Feb 21, 2012, 7:46 AM
  5. Replies: 4
    Last Post: Jan 17, 2011, 3:35 PM

Posting Permissions