ItemTag validation Error

  1. #1

    ItemTag validation Error

    Hi, I published my project and get the following exception:

    ItemTag validation (_tkn_1): Reference token (ext.net.global.icons) was not found.
    
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 
    
    Exception Details: System.Exception: ItemTag validation (_tkn_1): Reference token (ext.net.global.icons) was not found.
    
    Source Error: 
    
    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
    
    Stack Trace: 
    
    
    [Exception: ItemTag validation (_tkn_1): Reference token (ext.net.global.icons) was not found.]
       Transformer.NET.ItemTag.Validate() +156
       Transformer.NET.TextTransformer.Handle() +159
       Transformer.NET.TextTransformer.Transform(List`1 tokensType, Dictionary`2 variables) +28
       Transformer.NET.TextTransformer.Transform(List`1 tokensType) +11
       Transformer.NET.TextTransformer.Transform() +27
       Ext.Net.ExtNetTransformer.Transform(String text) +167
       Ext.Net.InitScriptFilter.Transform() +77
       Ext.Net.InitScriptFilter.Flush() +47
       System.Web.HttpWriter.FilterIntegrated(Boolean finalFiltering, IIS7WorkerRequest wr) +9510069
       System.Web.HttpResponse.FilterOutput() +104
       System.Web.CallFilterExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +49
       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +69
    Any idea?

    Thanks
  2. #2
    Any idea?
    Not really.

    Maybe ensure the Web.config on the server is correctly configured.

    http://examples2.ext.net/#/Getting_S...le_Web.config/
    Geoffrey McGill
    Founder & CEO
  3. #3
    Thanks @geoffrey

    This is my Web.config

    
    <?xml version="1.0" encoding="utf-8"?>
    <configuration>
      <configSections>
        <section name="extnet" type="Ext.Net.GlobalConfig" requirePermission="false" />
      </configSections>
      <appSettings>
        <add key="webpages:Version" value="3.0.0.0" />
        <add key="webpages:Enabled" value="false" />
        <add key="ClientValidationEnabled" value="true" />
        <add key="UnobtrusiveJavaScriptEnabled" value="true" />
    	  <add key="Core.Connetion.String" value="Data Source=Server;Initial Catalog=Database;User Id=user;Password=1234;" />
        <add key="Core.Database.Provider" value="MSSQL" />
      </appSettings>
      <extnet theme="Gray" />
      <system.web>
        <compilation targetFramework="4.5" />
        <httpRuntime targetFramework="4.5" />
        <httpHandlers>
          <add path="*/ext.axd" verb="*" type="Ext.Net.ResourceHandler" validate="false" />
        </httpHandlers><httpModules>
          <add name="DirectRequestModule" type="Ext.Net.DirectRequestModule, Ext.Net" />
        </httpModules>
        <pages>
          <controls>
            <add assembly="Ext.Net" namespace="Ext.Net" tagPrefix="ext" />
          </controls>
          <namespaces>
            <add namespace="Ext.Net" />
            <add namespace="Ext.Net.MVC"/>
          </namespaces>
        </pages>
      </system.web>
      <system.webServer>
        <validation validateIntegratedModeConfiguration="false" />
        <modules>
          <add name="DirectRequestModule" preCondition="managedHandler" type="Ext.Net.DirectRequestModule, Ext.Net" />
        </modules>	
        <handlers>
          <add name="DirectRequestHandler" verb="*" path="*/ext.axd" preCondition="integratedMode" type="Ext.Net.ResourceHandler" />
        </handlers>
      </system.webServer>
      <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <dependentAssembly>
            <assemblyIdentity name="System.Web.Mvc" publicKeyToken="31bf3856ad364e35" />
            <bindingRedirect oldVersion="0.0.0.0-5.0.0.0" newVersion="5.0.0.0" />
          </dependentAssembly>
          <dependentAssembly>
            <assemblyIdentity name="System.Web.WebPages" publicKeyToken="31bf3856ad364e35" />
            <bindingRedirect oldVersion="0.0.0.0-3.0.0.0" newVersion="3.0.0.0" />
          </dependentAssembly>
        </assemblyBinding>
      </runtime>
    </configuration>
    I also tried with the example config and it didn't work!

    <?xml version="1.0"?>
    <configuration>
      <configSections>
        <section name="extnet" type="Ext.Net.GlobalConfig" requirePermission="false" />
      </configSections>
      <extnet theme="Gray" />
      <system.web>
        <httpHandlers>
          <add path="*/ext.axd" verb="*" type="Ext.Net.ResourceHandler" validate="false" />
        </httpHandlers>
        <httpModules>
          <add name="DirectRequestModule" type="Ext.Net.DirectRequestModule, Ext.Net" />
        </httpModules>
        <pages>
          <controls>
            <add assembly="Ext.Net" namespace="Ext.Net" tagPrefix="ext" />
          </controls>
          <namespaces>
            <add namespace="Ext.Net"/>
            <add namespace="Ext.Net.MVC"/>
          </namespaces>
        </pages>
      </system.web>
      <system.webServer>
        <validation validateIntegratedModeConfiguration="false" />		
        <modules>
          <add name="DirectRequestModule" preCondition="managedHandler" type="Ext.Net.DirectRequestModule, Ext.Net" />
        </modules>		
        <handlers>
          <add name="DirectRequestHandler" verb="*" path="*/ext.axd" preCondition="integratedMode" type="Ext.Net.ResourceHandler" />
        </handlers>
      </system.webServer>  
      <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">            
          <dependentAssembly>
            <assemblyIdentity name="System.Web.Mvc" publicKeyToken="31bf3856ad364e35" />
            <bindingRedirect oldVersion="1.0.0.0-5.0.0.0" newVersion="5.0.0.0" />
          </dependentAssembly>
          <dependentAssembly>
            <assemblyIdentity name="System.Web.Helpers" publicKeyToken="31bf3856ad364e35" />
            <bindingRedirect oldVersion="1.0.0.0-3.0.0.0" newVersion="3.0.0.0" />
          </dependentAssembly>
          <dependentAssembly>
            <assemblyIdentity name="System.Web.WebPages" publicKeyToken="31bf3856ad364e35" />
            <bindingRedirect oldVersion="1.0.0.0-3.0.0.0" newVersion="3.0.0.0" />
          </dependentAssembly>      
        </assemblyBinding>
      </runtime>
    </configuration>
  4. #4
    The error occurs when I use any icon. No matter how or where you use it, fails.

    Example 1

                items.Add(new Button
                {
                    Text = "Mi Cuenta",
                    Margins = "0 20 0 0",
                    Menu =
                    {
                        new Menu{
                            Items = { 
                                new MenuItem { Text =  "Configuraci?n", Icon = Icon.Cog },
                                new MenuItem { Text =  "Acerca de...", Icon = Icon.Information }
                            }
                        }
                    }
                });

    Example 2

                .Items(Html.X()
                    .Button()
                    .Text("Test")
                    .Icon(Icon.Book)
                    .IconAlign(IconAlign.Top)
                    .ArrowAlign(ArrowAlign.Right)
                    .Scale(ButtonScale.Large)
                    .RowSpan(3)
                )
    The error occurs in the hosting server. Local works ok.
  5. #5
    Hi @logidat,

    Please provide a full (but simplified as much as you can) test case to reproduce the problem.
  6. #6
    I could not fix the problem so I changed my hosting provider and it worked. Please close the thread. Thanks

Similar Threads

  1. Replies: 17
    Last Post: Jun 26, 2014, 3:43 PM
  2. Replies: 0
    Last Post: Jun 23, 2014, 2:08 PM
  3. Replies: 5
    Last Post: Jun 11, 2013, 8:46 AM
  4. Validation Status Error
    By manbaul in forum 2.x Help
    Replies: 2
    Last Post: Apr 27, 2013, 2:29 AM
  5. Replies: 3
    Last Post: Jul 11, 2011, 10:43 AM

Tags for this Thread

Posting Permissions