Fail to run after set FORMS authentication mode in webconfig

  1. #1

    Fail to run after set FORMS authentication mode in webconfig

    i use installer package to install coolite and things goes fine at begining, but after i setup the forms authentication , it promp .EXT is not definded

    <authentication mode="Forms">
        <forms loginUrl="Login.aspx" name=".ASPXFORMSAUTH" defaultUrl="Index.aspx"/>
    </authentication>
    and below is part of my Login.aspx

    </head>
    <body>
        <cool:ScriptManager ID="ScriptManager1" runat="server" Hide="True" />
        <form id="form1" runat="server">    
        <div id="centeredcontent">
        
            <cool:Panel Visible="true" ID="p_Login" runat="server" BodyStyle="padding: 6px;"
    it fail at this line when i run it in debug mode

    //<![CDATA[
    Ext.BLANK_IMAGE_URL='/cool/extjs/resources/images/gray/s/gif/cool.axd' ....
  2. #2

    RE: Fail to run after set FORMS authentication mode in webconfig

    This is an interesting problem and I suspect I know what might be happening, although at the moment, I can not reproduce locally.

    Does the error still occur if you change the CleanResourceUrl property to "false" on the ScriptManager control?

    Example

    <cool:ScriptManager ID="ScriptManager1" runat="server" CleanResourceUrl="false" />
    Do you have an <authorization> node in your web.config file? If yes, can you post for us to review.
    Geoffrey McGill
    Founder & CEO
  3. #3

    RE: Fail to run after set FORMS authentication mode in webconfig

    it's work ~~ however it's change the default style to "GRAY"

    but it's ok after i Hide the script manager from UI Designer and set ...

    <cool:ScriptManager ID="ScriptManager1" CleanResourceUrl="False" Theme="Default" Hide="true" runat="server" />
    thanks
  4. #4

    RE: Fail to run after set FORMS authentication mode in webconfig

    The results you experienced with the ScriptManager somehow changing the Theme when the CleanResourceUrl properties changes is pretty wierd. I double-checked all the code around those two properties and everything appears to work correctly. I will keep my eye on the problem and certainly fix immediately if I figure out a way to reproduce.

    Does the Gray Theme render if you have the following ScriptManager tag?

    <cool:ScriptManager ID="ScriptManager1" CleanResourceUrl="False" runat="server" />
    Geoffrey McGill
    Founder & CEO
  5. #5

    RE: Fail to run after set FORMS authentication mode in webconfig

    in system.web




    
    
    
    
    <location path="extjs">
    
    
    <system.web>
    
    
    <authorization>
    
    
    <allow users="?" />
    
    
    </authorization>
    
    
    </system.web>
    
    
    </location>
    
    
    <location path="coolite">
    
    
    <system.web>
    
    
    <authorization>
    
    
    <allow users="?" />
    
    
    </authorization>
    
    
    </system.web>
    
    
    </location>

Similar Threads

  1. [CLOSED] Forms authentication RedirectFromLoginPage not working
    By CarWise in forum 2.x Legacy Premium Help
    Replies: 5
    Last Post: Jun 05, 2012, 1:25 PM
  2. [CLOSED] Caching issue when forms authentication is enabled
    By jskibo in forum 1.x Legacy Premium Help
    Replies: 10
    Last Post: Sep 22, 2009, 12:25 PM
  3. [CLOSED] AjaxMethod and Forms authentication
    By tdracz in forum 1.x Legacy Premium Help
    Replies: 3
    Last Post: Jul 20, 2009, 7:57 PM
  4. Webconfig
    By mono in forum 1.x Help
    Replies: 1
    Last Post: Mar 10, 2009, 6:43 AM
  5. [CLOSED] Forms Authentication and Coolite (Ext)
    By reinout.mechant@imprss.be in forum 1.x Legacy Premium Help
    Replies: 2
    Last Post: Mar 04, 2009, 11:18 AM

Posting Permissions