[CLOSED] ComponentLoader.ToConfig on DateField not working

  1. #1

    [CLOSED] ComponentLoader.ToConfig on DateField not working

    Hi,

    I'm trying to get the config of one DateField.
    Code:
    DateField df = new DateField();
    
    df.Text = "02/25/1987";
    
    string test = ComponentLoader.ToConfig(df);
    If i call the ComponentLoader.ToConfig before setting a value to Text property, the code works beautifully.
    If i set the value of the Text property before, i get an error: "Error during ClientConfig initialization. FormatProxy - Token PropertyName in state Property would result in an invalid JSON object. Path ''.".
    Updated to the last version on the NuGet and the error persists.

    What can i do?

    Thanks in advance,
    Last edited by Daniil; Apr 30, 2014 at 12:24 PM. Reason: [CLOSED]
  2. #2
    Hi Raphael,

    I cannot reproduce the exception using your code.

    Though, in any way I don't think you should use a DateField's Text. Please use its SelectedDate.
  3. #3
    Daniil,

    Once again, worked like a charm. Thanks.

    You can mark this thread as closed.

Similar Threads

  1. MinDate Property Does not working in DateField
    By anil420anil420@gmail.com in forum 1.x Help
    Replies: 8
    Last Post: Feb 15, 2012, 5:41 AM
  2. [CLOSED] Menu.ToConfig() fails in a service
    By randy85253 in forum 1.x Legacy Premium Help
    Replies: 1
    Last Post: Jan 13, 2012, 9:29 PM
  3. Replies: 5
    Last Post: Sep 14, 2011, 4:51 PM
  4. [1.0] DateField.Format not working
    By nextSTEP in forum 1.x Help
    Replies: 4
    Last Post: Nov 18, 2010, 10:18 AM
  5. Datefield Readonly not working
    By EzaBlade in forum 1.x Help
    Replies: 0
    Last Post: Feb 12, 2009, 9:28 AM

Tags for this Thread

Posting Permissions