How to force BorderLayout splitter to have border?

  1. #1

    How to force BorderLayout splitter to have border?

    This is a bit of a cosmetic problem. When you have a BorderLayout with panels, it gives a rather thick looking border around each of the panels, as you can see in attachment 1. It seems to be MUCH cleaner if you turn the panel borders off, as you can see in Attachment 2. However, there is an undesired consequence of this, in which the splitter bar now has a white (or non existent) border, as circled in red Attachment 3. Can this be fixed somehow??
  2. #2

    RE: How to force BorderLayout splitter to have border?

    I think you will get the desired effect if you set Border="false" on the parent Panel (first Panel inside region). And, don't disable the borders on the inner Panels ("Draft Requests").

    Or, If you want an border just on one edge, you can set Border="false", then add back the single border with Css. 


    Hope this helps.


    Geoffrey McGill
    Founder & CEO

Similar Threads

  1. [CLOSED] RowLayout with Splitter inside BorderLayout
    By softmachine2011 in forum 2.x Legacy Premium Help
    Replies: 6
    Last Post: May 22, 2012, 8:11 AM
  2. Replies: 0
    Last Post: Apr 19, 2012, 3:52 PM
  3. Replies: 0
    Last Post: Aug 16, 2009, 4:25 AM
  4. Replies: 0
    Last Post: May 30, 2009, 10:18 PM
  5. BorderLayout splitter delay when using AutoLoad
    By dbassett74 in forum 1.x Help
    Replies: 3
    Last Post: May 07, 2009, 7:15 PM

Posting Permissions