[CLOSED] Debug Error

  1. #1

    [CLOSED] Debug Error

    Hi

    I have a page (Container.aspx) with panel container:

    <body>
        <form id="form1" runat="server">
        <ext:ResourceManager runat="server" Theme="Gray" DirectMethodNamespace="SIU.DirectMethods" >
        </ext:ResourceManager>
        <ext:Viewport runat="server" Layout="Border">
            <Items>
                <ext:Panel ID="pnlHeader" runat="server" Header="false" Region="North" Border="false" Height="100">
                        ...
                </ext:Panel>
                <ext:Panel ID="pnlLeft" runat="server" Width="250" Border="false" Region="West" Layout="Fit">
                        ...
                </ext:Panel>
                <ext:Panel ID="pnlContent" runat="server" Margins="5" Region="Center" BodyPadding="13">
                    <Loader runat="server" Mode="Frame" AutoLoad="false" ShowWarningOnFailure="false">
                        <LoadMask ShowMask="true" />
                    </Loader>
                </ext:Panel>
            </Items>
        </ext:Viewport>
        </form>
    </body>
    From selection in pnlLeft, I load aspx pages (same site) in the pnlContent as follows:

    [DirectMethod]
    public void LoadPageMenu(string reqPage, string idObj = "")
    {
    ...
    pnlContent.Loader.Url = reqPage;
    pnlContent.LoadContent();
    ...
    }
    This aspx pages load others pages (same site) in the same pnlContent, calling one javascript function in the page Container.aspx using parent.jsFunction. Sometimes, and randomly, I get this error message when to load one page:

    Click image for larger version. 

Name:	Request Failure.png 
Views:	25 
Size:	7.2 KB 
ID:	9501

    After, the loaded page close and, in the pnlContent, is loaded the loginUrl (authentication forms). Looks like session timeout, but this is configured in 15 minutes.

    I have a log error in the server side but doesn't save anything about this. In the chrome's console doesn't show anything. How can I solve or trace this error?

    Thank you.
    Last edited by Daniil; Apr 16, 2014 at 12:15 AM. Reason: [CLOSED]
  2. #2
    Hi @Kricher,

    It still looks like the Session ends. The Session timeout is not the only reason of that. For example, if change/restart an application, the Session will be reset.

    Sometimes, and randomly, I get this error message when to load one page:
    Some certain thing is probably happening before that "randomly"...

    Also I should say that Ext.NET doesn't reset Session. I think the problem is outside of Ext.NET scope.
    Last edited by Daniil; Apr 07, 2014 at 6:08 PM.
  3. #3
    Hi Daniil. Thanks for your answer.

    I don't understand this:

    Quote Originally Posted by Daniil View Post
    The Session timeout is not the only reason of that. For example, if change/restart an application, the Session will be reset.
    The application can change and abandon the Session, but I don't know when one ASP .NET application restart. Can you explain me please? Anyway, in the application, I don't execute Session.Abandon() or FormsAuthentication.SignOut(). I am sure that Session's timeout doesn't happen too, because It's configured in 15 minutes and this problem happens before.

    Is there some way for catch this error (client side) before this is showed ?

    Thank you for your help.
  4. #4
    Quote Originally Posted by Kricher View Post
    The application can change and abandon the Session, but I don't know when one ASP .NET application restart. Can you explain me please?
    Probably, when a server detects that an application has been changed. I am not sure also.

    Also I have heard about the problems with Session if use iframes. At least, in IE.
    http://www.stephensaw.me/session-los...-using-iframe/

    Maybe, it is somehow related to the problem.

    Quote Originally Posted by Kricher View Post
    Is there some way for catch this error (client side) before this is showed ?
    I would try with a DirectMethod's failure handler and with a Loader's Exception listener.

Similar Threads

  1. [CLOSED] Exception in extnet-all-debug.js
    By michaeld in forum 2.x Premium Help
    Replies: 7
    Last Post: Oct 01, 2013, 4:05 PM
  2. Ext.net.Debug + Stores
    By peter.campbell in forum 1.x Help
    Replies: 2
    Last Post: Mar 29, 2011, 11:54 AM
  3. Replies: 9
    Last Post: Apr 12, 2010, 5:00 PM
  4. i cant debug coolite on MVC
    By chsn1 in forum 1.x Help
    Replies: 0
    Last Post: Nov 12, 2009, 6:13 AM
  5. [CLOSED] intellisense and debug mode.
    By pkellner in forum 1.x Premium Help
    Replies: 6
    Last Post: Sep 29, 2008, 5:34 PM

Tags for this Thread

Posting Permissions