Model created by StoreFor<> and multi HasManayAssociation Attribute

Page 2 of 2 FirstFirst 12
  1. #11
    Quote Originally Posted by Baidaly View Post
    I've asked my colleagues, probably they can help us.
    Thank you so much Baidaly.
  2. #12
    Quote Originally Posted by bobae7 View Post
    Anyway thanks for the reply and hopefully defined in Ext.NET AbstractAssociationAttribute in AbstractAssociationAttribute.cs file
    AllowMultiple = true works fine soon ^^
    Well, it is already there. Otherwise, you would get a compiler error like "Duplicate 'HasManyAssociation' attribute".

    For some reason, the OnMetadataCreated handler is executed for the first attribute only despite it is defined several times.

    Seems, this guy has exactly the same problem.
    http://stackoverflow.com/questions/1...the-same-field

    We are investigating.

    Thank you for catching this problem.
    Last edited by Daniil; Nov 13, 2013 at 12:46 PM.
  3. #13
    Quote Originally Posted by Daniil View Post
    Well, it is already there. Otherwise, you would get a compiler error like "Duplicate 'HasManyAssociation' attribute".

    For some reason, the OnMetadataCreated handler is executed for the first attribute only despite it is defined several times.

    Seems, this guy has exactly the same problem.
    http://stackoverflow.com/questions/1...the-same-field

    We are investigating.

    Thank you for catching this problem.
    Thank you for reply and got so much help from your posts.

    I didn't mean to add AllowMultiple = true ^^.
    Already saw the files and checked it's in there... but not working at the moment.

    So I mean I hope it works properly then resolve my problem ~~

    Anyway thanks again and I really appreciate your works.
  4. #14
    Quote Originally Posted by bobae7 View Post
    I didn't mean to add AllowMultiple = true ^^.
    Already saw the files and checked it's in there... but not working at the moment.

    So I mean I hope it works properly then resolve my problem ~~
    Ah, sorry. I misunderstood.

    Yes, there is some problem with the IMetadataAware interface.
  5. #15
    Fixed in SVN
    The fix will be available in the next public release
    Vladimir Shcheglov
    Sr. Developer
  6. #16
    Quote Originally Posted by Vladimir View Post
    Fixed in SVN
    The fix will be available in the next public release
    Thank you so much ^^.
Page 2 of 2 FirstFirst 12

Similar Threads

  1. Replies: 1
    Last Post: Jul 30, 2013, 4:36 PM
  2. [CLOSED] How to use StoreFor Model
    By UnifyEducation in forum 2.x Premium Help
    Replies: 3
    Last Post: Oct 18, 2012, 2:09 PM
  3. Replies: 0
    Last Post: Aug 01, 2012, 2:20 AM
  4. Replies: 2
    Last Post: Aug 09, 2011, 11:38 AM
  5. Multi Select - JIT
    By amitpareek in forum Open Discussions
    Replies: 1
    Last Post: Dec 09, 2008, 10:31 AM

Tags for this Thread

Posting Permissions