[CLOSED] Problem with Version 2.3.1

  1. #1

    [CLOSED] Problem with Version 2.3.1

    Good Evening all

    we do the first Tests with the new Version of Ext.Net (2.3.1).
    We use a Assembly Redirect for this Tests...

    On most of our existing Pages an Error occurs : "Could not load type 'AjaxReadDataEventHandler' from assembly 'Ext.Net, Version=2.3.1.41036..."
    Any Idea what causes Error ?

    Can't see anything in the Release Documents about this ?

    Peter
    Last edited by Daniil; Oct 29, 2013 at 12:44 PM. Reason: [CLOSED]
  2. #2
    Hi Peter,

    I cannot reproduce with this test case. Can you?

    Example
    <%@ Page Language="C#" %>
    
    <%@ Register Assembly="Ext.Net" Namespace="Ext.Net" TagPrefix="ext" %>
    <%@ Import Namespace="System.Collections.Generic" %>
    
    <script runat="server">
        public List<object> MyData = new List<object> 
        { 
            new { test = "test1" },
            new { test = "test2" },
            new { test = "test3" },
            new { test = "test4" },
            new { test = "test5" },
            new { test = "test6" },
            new { test = "test7" },
            new { test = "test8" },
            new { test = "test9" }
        };
    
        protected void Store_ReadData(object sender, StoreReadDataEventArgs e)
        {
            List<object> data = this.MyData;
            var limit = e.Limit;
            if ((e.Start + e.Limit) > data.Count)
            {
                limit = data.Count - e.Start;
            }
            List<object> rangeData = (e.Start < 0 || limit < 0) ? data : data.GetRange(e.Start, limit);
            e.Total = data.Count;
            (sender as Store).DataSource = rangeData;
        }
    </script>
    
    <!DOCTYPE html>
    
    <html>
    <head runat="server">
        <title>Ext.NET v2 Example</title>
    </head>
    <body>
        <form runat="server">
            <ext:ResourceManager runat="server" />
            <ext:GridPanel ID="GridPanel1" runat="server">
                <Store>
                    <ext:Store runat="server" OnReadData="Store_ReadData" PageSize="3">
                        <Model>
                            <ext:Model runat="server">
                                <Fields>
                                    <ext:ModelField Name="test" />
                                </Fields>
                            </ext:Model>
                        </Model>
                        <Proxy>
                            <ext:PageProxy>
                                <Reader>
                                    <ext:JsonReader />
                                </Reader>
                            </ext:PageProxy>
                        </Proxy>
                    </ext:Store>
                </Store>
                <ColumnModel runat="server">
                    <Columns>
                        <ext:Column runat="server" Text="Test" DataIndex="test" />
                    </Columns>
                </ColumnModel>
                <BottomBar>
                    <ext:PagingToolbar runat="server" />
                </BottomBar>
            </ext:GridPanel>
        </form>
    </body>
    </html>
    Could you elaborate the following, please?
    We use a Assembly Redirect for this Tests...
  3. #3
    Hi Daniil

    your Example works !
    What now ?
  4. #4
    Please comment this
    Quote Originally Posted by Daniil View Post
    Could you elaborate the following, please?

    We use a Assembly Redirect for this Tests...
    and provide us with a test case to reproduce.
  5. #5
    Good Morning all

    Daniil, I have to postpone this example. We're currently in a user testing phase and very busy.
    I'll come back to this end of next week. Can we let this thread open ?

    Peter
  6. #6
    No problem, we will leave it open.

    Anyway, even if it will be closed (it might be since we are closing threads in a while if no response from a member), please feel free to post any new information regarding the issue.

Similar Threads

  1. [CLOSED] GridPanel problem after upgrading to version 2.2
    By ermanni.info in forum 2.x Legacy Premium Help
    Replies: 3
    Last Post: Sep 10, 2013, 5:09 AM
  2. [CLOSED] Problem installing last mvc version from nuget
    By sivsa in forum 2.x Legacy Premium Help
    Replies: 4
    Last Post: Mar 13, 2013, 11:59 AM
  3. Ext.Fly problem in 2.x version
    By GolineTidus in forum 2.x Help
    Replies: 4
    Last Post: Nov 27, 2012, 8:27 AM
  4. [CLOSED] Problem under Opera last version
    By feanor91 in forum 2.x Legacy Premium Help
    Replies: 32
    Last Post: Jul 13, 2012, 2:22 PM
  5. combo edit problem in 0.8 version
    By Dinesh.T in forum 1.x Help
    Replies: 2
    Last Post: Jul 22, 2009, 11:15 AM

Posting Permissions