[CLOSED] SharePoint 2013 with Ext.Net 1.3

  1. #1

    [CLOSED] SharePoint 2013 with Ext.Net 1.3

    I have a SharePoint 2013 site and when i try to deploy a web-part or custom aspx page with Ext.Net I received this error message "Sys.ArgumentException: The format string is invalid." This error was reported before and been solved in the ext.js check the solution here

    I tried the workarounds but it didn't work. Seems the issue is still exist when Ext.NET is used with SharePoint2013.
    Please advice
    Last edited by Daniil; May 27, 2013 at 7:12 AM. Reason: [CLOSED]
  2. #2
    Hi @Istofix,

    Well, this exception
    Sys.ArgumentException: The format string is invalid.
    can be caused by many things.

    I doubt you are facing the same issue as discussed in the thread that you mentioned. Moreover, I guess that fix has been included in v1.3.

    Unfortunately, there are still many problems of using
    <asp:ScriptManager>
    and
    <ext:ResourceManager>
    at the same page.

    Some of them are just unsolvable in the context of Ext.NET v1 / ExtJS 3, because fixing would require hard reworking of many things.

    The problem was solved in Ext.NET v2 / ExtJS 4.

    Returning to your specific issue.

    Could you post a simple test case to reproduce?
  3. #3
    Quote Originally Posted by Daniil View Post
    Some of them are just unsolvable in the context of Ext.NET v1 / ExtJS 3, because fixing would require hard reworking of many things.
    The problem was solved in Ext.NET v2 / ExtJS 4.
    I'll upgrade the code to 2.2; hopefully this will fix the issue. Anyway can we assume that Ext.NET should work with SharePoint usually?
  4. #4
    Please note that migrating the existing application from v1 to v2 is quite a major step.

    I think it should work. At least, this member has got SharePoint + Ext.NET v1 working.
    http://forums.ext.net/showthread.php?17320
  5. #5
    Thanks Daniil, we updated to 2.2 and everything is working fine now.

Similar Threads

  1. Using Coolite with Sharepoint
    By dukefama in forum 1.x Help
    Replies: 0
    Last Post: Oct 20, 2010, 2:52 PM
  2. AjaxMethod - Sharepoint webpart
    By toinho in forum 1.x Help
    Replies: 2
    Last Post: Feb 11, 2009, 12:08 PM
  3. SharePoint
    By randy85253 in forum 1.x Help
    Replies: 17
    Last Post: Jan 15, 2009, 11:49 AM
  4. [RePost] SharePoint
    By randy85253 in forum 1.x Help
    Replies: 0
    Last Post: Oct 14, 2008, 10:11 PM

Tags for this Thread

Posting Permissions