[CLOSED] GridPanel delete icon display problem on TabPanel

Page 1 of 2 12 LastLast
  1. #1

    [CLOSED] GridPanel delete icon display problem on TabPanel

    Hi guys,
    I have a problem of delete icon display of the GridPanel.
    I have a TabPanel wich contains panels. One of this panel contains a Gridpanel.
    On the image below, I have a grid on the left (1) and when I change row the tabPanel (2) is updated. Like you see TabPanel contains "Organisations access rights" panel which contains again GriPanel (Associations).
    Click image for larger version. 

Name:	Untitled.png 
Views:	20 
Size:	31.3 KB 
ID:	6138

    So when the "Organisations access rights" panel is activated and I change row (1) I see delete icon. But when I activate "Modul access rights" or "Telecom category access rights" and I change the row (1) and when I re activate "Organisations access rights" panel I don't see delete icon.
    Click image for larger version. 

Name:	Untitled1.png 
Views:	17 
Size:	24.6 KB 
ID:	6140Click image for larger version. 

Name:	Untitled2.png 
Views:	13 
Size:	29.5 KB 
ID:	6141

    In conclusion when I update the content of the TabPanel and if the tab which contains gridpanel is not activated I don't see delete icon.

    The application is in webform. Can you please help me ?
    Last edited by Daniil; May 03, 2013 at 2:06 PM. Reason: [CLOSED]
  2. #2
    Hi @Tactem,

    What Ext.NET version are you testing with?
  3. #3
    Hi Daniil I'm testing with the version 2.1.20440.

    Quote Originally Posted by Daniil View Post
    Hi @Tactem,

    What Ext.NET version are you testing with?
  4. #4
    Sorry, I am not sure what this version is. Where did you get it from?
  5. #5
    It was the last version of the svn 2.1
    I also have the 2.2 version of webform.
  6. #6
    I replaced the 2.1 version by the svn 2.2.0.23567 version but I have the same problem.
  7. #7
    I can't reproduce.

    Please provide a test case.
  8. #8
    Daniil,

    I added a example. In my second arry grid the company name doesn't display I don't know why but you can see my problem with delete icon.

    Test.aspx.txtTest.aspx.cs.txt
  9. #9
    When I change array grid selection and if not "Organisation access rights" is not activated first, then when I activate it after selection change the icon disappears.

    Please tell me if you can reproduce it.

    Quote Originally Posted by Tactem View Post
    Daniil,

    I added a example. In my second arry grid the company name doesn't display I don't know why but you can see my problem with delete icon.

    Test.aspx.txtTest.aspx.cs.txt
  10. #10
    Please post a sample direct here wrapping in code tags.

    Please put the code behind direct to the ASPX page, see Example (Very Helpful) here.
    Forum Guidelines For Posting New Topics
Page 1 of 2 12 LastLast

Similar Threads

  1. Tabpanel and Gridpanel problem
    By Akpenob in forum 2.x Help
    Replies: 2
    Last Post: Aug 20, 2012, 10:30 AM
  2. [CLOSED] ArrowRefresh icon won't display
    By vadym.f in forum 1.x Premium Help
    Replies: 3
    Last Post: Feb 27, 2012, 2:10 PM
  3. [CLOSED] GridPanel display problem
    By Stefanaccio in forum 1.x Premium Help
    Replies: 3
    Last Post: Oct 21, 2010, 11:58 AM
  4. [CLOSED] GridPanel display problem
    By frytas in forum 1.x Premium Help
    Replies: 1
    Last Post: Jul 01, 2010, 3:08 PM
  5. [CLOSED] Tabpanel + Gridpanel: display issue
    By reinout.mechant@imprss.be in forum 1.x Premium Help
    Replies: 2
    Last Post: Jun 26, 2009, 10:58 AM

Posting Permissions