[CLOSED] IIS 7.5 deployment

  1. #1

    [CLOSED] IIS 7.5 deployment

    I'm deployng to a windows 2008 server box with IIS 7.5 configured for ASP.NET

    I deployed a minimal test web site

    
    <%@ Page Title="Home page" Language="C#" MasterPageFile="~/Site.master" AutoEventWireup="true"
        CodeFile="Default.aspx.cs" Inherits="_Default" %>
    
    <%@ Register Assembly="Ext.Net" Namespace="Ext.Net" TagPrefix="ext" %>
    <asp:Content ID="HeaderContent" runat="server" ContentPlaceHolderID="HeadContent">
    </asp:Content>
    <asp:Content ID="BodyContent" runat="server" ContentPlaceHolderID="MainContent">
        <ext:ResourceManager ID="ResourceManager1" runat="server">
        </ext:ResourceManager>
        <ext:Window ID="Window1" runat="server" Collapsible="true" Height="185" Icon="Application"
            Title="Title" Width="350">
            <Items>
            </Items>
        </ext:Window>
    </asp:Content>
    with following minimal standard web.config
    <?xml version="1.0"?>
    <configuration>
      <configSections>
        <section name="extnet" type="Ext.Net.GlobalConfig" requirePermission="false" />
      </configSections>
    
      <extnet scriptMode="Release" theme="Gray" />
      <!-- See Property Options below in Sec IV. -->
    
      <!-- 
            The following system.web section is only requited for running ASP.NET AJAX under Internet
            Information Services 6.0 (or earlier).  
            
            This section is not necessary for IIS 7.0 or later, although does not have to be removed.
        -->
      <system.web>
        <httpHandlers>
          <add path="*/ext.axd" verb="*" type="Ext.Net.ResourceHandler" validate="false" />
        </httpHandlers>
        <httpModules>
          <add name="DirectRequestModule" type="Ext.Net.DirectRequestModule, Ext.Net" />
        </httpModules>
        <pages>
          <controls>
            <add assembly="Ext.Net" namespace="Ext.Net" tagPrefix="ext" />
          </controls>
        </pages>
      </system.web>
    
      <!-- 
            The system.webServer section is required for running ASP.NET AJAX under Internet Information Services 7.0 and next.
            
            It is not necessary for previous version of IIS, although does not have to be removed. 
        -->
      <system.webServer>
        <validation validateIntegratedModeConfiguration="false"/>
        <modules>
          <add
                    name="DirectRequestModule"
                    preCondition="managedHandler"
                    type="Ext.Net.DirectRequestModule, Ext.Net"
                    />
        </modules>
        <handlers>
          <add
                    name="DirectRequestHandler"
                    verb="*"
                    path="*/ext.axd"
                    preCondition="integratedMode"
                    type="Ext.Net.ResourceHandler"
                    />
        </handlers>
      </system.webServer>
      <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <dependentAssembly>
            <assemblyIdentity name="Newtonsoft.Json" publicKeyToken="30ad4fe6b2a6aeed" />
            <bindingRedirect oldVersion="1.0.0.0-4.5.9" newVersion="4.5.10" />
          </dependentAssembly>
          <dependentAssembly>
            <assemblyIdentity name="Ext.Net.Utilities" publicKeyToken="2c34ac34702a3c23" />
            <bindingRedirect oldVersion="0.0.0.0-2.0.1" newVersion="2.1.0" />
          </dependentAssembly>
          <dependentAssembly>
            <assemblyIdentity name="Transformer.NET" publicKeyToken="e274d618e7c603a7" />
            <bindingRedirect oldVersion="0.0.0.0-2.0.0" newVersion="2.1.0" />
          </dependentAssembly>
        </assemblyBinding>
      </runtime>
    </configuration>

    I got following error regarding MVC lack

    Errore del parser
    Descrizione: Errore durante l'analisi di una risorsa necessaria per soddisfare la richiesta. Rivedere i dettagli relativi all'errore e modificare in modo appropriato il file di origine.

    Messaggio di errore del parser: Could not load file or assembly 'System.Web.Mvc, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. Impossibile trovare il file specificato.

    Errore nel codice sorgente:
    Riga 5:  </asp:Content>
    Riga 6:  <asp:Content ID="BodyContent" runat="server" ContentPlaceHolderID="MainContent">
    Riga 7:      <ext:ResourceManager ID="ResourceManager1" runat="server">
    Riga 8:      </ext:ResourceManager>
    Riga 9:      <ext:Window ID="Window1" runat="server" Collapsible="true" Height="185" Icon="Application"
    ==============

    Please, do Ext.Net has prerequisites to be released to the destination box or else? I checked the release notes and it seems all needed components should be included..

    I had no issues doing the same relase in a environment in which Visual Studio 2010 SP1 was previously installed

    Do I need to follow a different procedure for versioni ext.net 2.1 and I miss it?

    My goal is to create a deployment kit to a new installed Windows Server 2008 R2 box

    Thanks in advance
    Last edited by Daniil; Jan 25, 2013 at 3:51 PM. Reason: Please use [CODE] tags, [CLOSED]
  2. #2
    Hi @tanky65,

    Probably, you need to install ASP.NET MVC 3 or use a WebForm Ext.NET build.
  3. #3
    Daniil,
    in the above test minimal project I added the distributable dependencies found from Visual Studio 2010 for the project itself. In those dependencies I cannot see MVC.
    Is it a prerequisite ? Should I add to the VS2010 project other dependencies?
    I would insert in the deployment kit all what the web appl. needs.
    bye
  4. #4
    Hi again,
    I added in the VS2010 project the System.Web.MVC 3.0 .NET component and I deployed again the webappl. Now it works.
    If possible, please, give me just a confirmation if it is always requested to add MVC, hence, if it is a prerequisite.
    Thanks and bye
  5. #5
    Quote Originally Posted by Daniil View Post
    or use a WebForm Ext.NET build.
    The WebForm build of v2.1.1 release doesn't require MVC to be installed.

Similar Threads

  1. Trouble in deployment
    By fosteliss in forum 2.x Help
    Replies: 6
    Last Post: Dec 13, 2012, 9:35 PM
  2. [CLOSED] Deployment to IIS guide
    By zwf in forum 2.x Premium Help
    Replies: 1
    Last Post: Oct 09, 2012, 12:21 PM
  3. Deployment issue
    By Sergio Majocchi in forum 1.x Help
    Replies: 2
    Last Post: Feb 08, 2012, 5:50 AM
  4. Coolite MVC Deployment
    By Mike in forum 1.x Help
    Replies: 4
    Last Post: Oct 20, 2009, 11:17 PM
  5. Deployment problem
    By romeox in forum 1.x Help
    Replies: 0
    Last Post: Jan 20, 2009, 5:17 AM

Tags for this Thread

Posting Permissions