[CLOSED] Prevent AutoPostback

  1. #1

    [CLOSED] Prevent AutoPostback


    I am using a combobox in a form panel, all rendered in a modal window. The window is hidden initially. Window is shown by a command in a grid. I want to prevent postback to server when user press 'Enter' key after selecting an item form the combobox. I tried AutoPostback = false on combobox but it still posts back. In other words, Page_Load is called and the configuration window disappears. What am I doing wrong?

                                    <ext:ComboBox runat="server" ID="rolesCombo" StoreID="Store1" AutoPostBack="false" ValueField="ID" DisplayField="Name" QueryMode="Local" Editable="false" AllowBlank="true" EmptyText="Select..." MatchFieldWidth="true" MultiSelect="false" Margins="0 5 0 0" Flex="1">
                                            <Select Handler="selectHandler(item,records);"></Select>
    Last edited by Baidaly; Feb 17, 2013 at 11:42 PM. Reason: [CLOSED]
  2. #2

    This is default browser behavior with form with single input field. You can fix it by adding hidden field on the form or removing form tag:

    <form runat="server">
  3. #3

    Here is a related discussion.
  4. #4
    All clear. Thank you. Please mark as closed.

Similar Threads

  1. [CLOSED] Disable AutoPostBack
    By Antonio09 in forum 2.x Premium Help
    Replies: 9
    Last Post: Dec 01, 2012, 3:34 AM
  2. ComboBox with AutoPostBack
    By Maia in forum 1.x Help
    Replies: 1
    Last Post: Jun 24, 2009, 2:25 PM
  3. GridCommand AutoPostBack
    By Timothy in forum Feature Requests
    Replies: 4
    Last Post: Apr 11, 2009, 9:46 AM
  4. ComboBox AutoPostBack
    By methode in forum 1.x Premium Help
    Replies: 1
    Last Post: Jan 09, 2009, 5:45 AM
  5. Button AutoPostBack to "false"
    By geoffrey.mcgill in forum Open Discussions
    Replies: 11
    Last Post: Sep 19, 2008, 4:55 PM

Posting Permissions