[CLOSED] Crystal Report

  1. #1

    [CLOSED] Crystal Report

    Hi all,

    I have a problem when using crystal report and ext.net components in the same page.
    When running the application, I have an error in the page:"allInOne.js".
    The error message is the following: "Microsoft JScript runtime error: Object doesn't support property or method 'getHTML'"
    Please find attached an image that show the error message.

    Is there a solution for this error? I use both ext.net v1.6 and v2.1.

    Thanks a lot.
    Attached Thumbnails CrystalReportExtError.png  
    Last edited by Daniil; Dec 26, 2012 at 1:25 PM. Reason: [CLOSED]
  2. #2
    More information required. Please see forum guidelines.
    Geoffrey McGill
    Founder & CEO
  3. #3
    Ok,
    Please find below the code:
    <%@ Page Language="C#" AutoEventWireup="true" CodeBehind="PaySlipReportForm.aspx.cs"
        Inherits="FPInternal.PL.EmployeePL.PaySlipReportForm" %>
    
    <%@ Register Assembly="CrystalDecisions.Web, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"
        Namespace="CrystalDecisions.Web" TagPrefix="CR" %>
    <%@ Register Assembly="Ext.Net" Namespace="Ext.Net" TagPrefix="ext" %>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head runat="server">
        <title></title>
    </head>
    <body>
        <ext:ResourceManager runat="server">
        </ext:ResourceManager>
        <form id="form1" runat="server">
        <div>
            <CR:CrystalReportViewer ID="CrystalReportViewer1" runat="server" Height="1202px"
                ReportSourceID="CrystalReportSource1" ToolPanelWidth="200px" Width="1104px" ToolPanelView="None"
                EnableDatabaseLogonPrompt="False" EnableParameterPrompt="False" HasCrystalLogo="False"
                HasToggleParameterPanelButton="False" EnableDrillDown="False" EnableTheming="False"
                HasToggleGroupTreeButton="False" DisplayToolbar="False" HasExportButton="False"
                HasPrintButton="False" HasSearchButton="False" />
            <CR:CrystalReportSource ID="CrystalReportSource1" runat="server">
                <Report FileName="PaySlipReport.rpt">
                </Report>
            </CR:CrystalReportSource>
            <asp:Button runat="server" ID="btnSave" Text="Save" OnClick="savePaySlip" />
            <asp:Button runat="server" ID="btnPrint" Text="Print" OnClick="printPaySlip" />
            <ext:Button runat="server" ID="btnSaveExt" Text="Save">
            </ext:Button>
        </div>
        </form>
    </body>
    </html>
    Please note that the problem occurs once I add the ext resource manager ( even if the ext button is not added).

    Thanks.
  4. #4
    Hello everybody,

    Ext.NET v2

    Ext.NET v2 removes ViewState by default. As far as I can understand it is required for Crystal Reports.

    Please set up DisableViewState="false" for the ResourceManager.

    Ext.NET v1

    I am unable to reproduce the problem.

    P.S. I had to remove everything from the Page directive leaving just:
    <%@ Page Language="C#"
    Also I had to remove OnClick="savePaySlip" and OnClick="printPaySlip", because I do not have definitions of these handlers.

    Well, it seems to be not a big deal. But everyday we test a huge amount of examples. It would be great help for us if you provided us with samples which we could just copy, paste and run without any changes. Thank you.
  5. #5
    Quote Originally Posted by Daniil View Post

    Ext.NET v1

    Well, it seems to be not a big deal. But everyday we test a huge amount of examples. It would be great help for us if you provided us with samples which we could just copy, paste and run without any changes. Thank you.
    Hi Daniil, I created a sample project and try to send it to you. However I can not upload it . The .rar extension is not supported when uploading file.

    What is your suggestion?

    Thanks.
  6. #6
    Yes, the forums restricts such file extensions.

    Well, this is our policy. We rejects any project which we didn't request. In our experience a test project is not required in 99% cases.

    Some more details are in our forums guidelines.
    Forum Guidelines For Posting New Topics
    More Information Required

    You posted an ASPX page which allows to reproduce the problem with Ext.NET v2.

    But it doesn't reproduce the issue with Ext.NET v1.

    So, my suggestion is the following. Please post a simplified ASPX to reproduce the problem in Ext.NET v1.
  7. #7
    Quote Originally Posted by Daniil View Post

    You posted an ASPX page which allows to reproduce the problem with Ext.NET v2.

    But it doesn't reproduce the issue with Ext.NET v1.
    Hi Daniil,

    In fact the previous code that I posted is extracted form a project where I use the v1.6 Ext.net.

    Regards.
  8. #8
    Good, but somehow it doesn't reproduce the problem on my side.

    Please demonstrate your Web.config.
  9. #9
    Quote Originally Posted by Daniil View Post
    Please demonstrate your Web.config.
    Hi,
    Please find below my Web.config:
    <?xml version="1.0"?>
    
    <!--
      For more information on how to configure your ASP.NET application, please visit
      http://go.microsoft.com/fwlink/?LinkId=169433
      -->
    
    <configuration>
    
    
      <configSections>
        <section name="extnet" type="Ext.Net.GlobalConfig" requirePermission="false" />
      </configSections>
    
      <extnet theme="Default" />
      <system.web>
    
        <httpHandlers>
          <add path="*/ext.axd" verb="*" type="Ext.Net.ResourceHandler" validate="false" />
        </httpHandlers>
        <httpModules>
          <add name="DirectRequestModule" type="Ext.Net.DirectRequestModule, Ext.Net" />
        </httpModules>
    
        <compilation debug="true" targetFramework="4.0">
          <assemblies>
            <add assembly="System.Data.Entity, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
          </assemblies>
        </compilation>
    
      </system.web>
    
      <system.webServer>
        <modules runAllManagedModulesForAllRequests="true">
          <add name="DirectRequestModule" preCondition="managedHandler" type="Ext.Net.DirectRequestModule, Ext.Net" />
        </modules>
        <validation validateIntegratedModeConfiguration="false" />
    
    
    
        <handlers>
          <add name="DirectRequestHandler" verb="*" path="*/ext.axd" preCondition="integratedMode" type="Ext.Net.ResourceHandler" />
        </handlers>
      </system.webServer>
      <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <dependentAssembly>
            <assemblyIdentity name="Newtonsoft.Json" publicKeyToken="30ad4fe6b2a6aeed" />
            <bindingRedirect oldVersion="1.0.0.0-4.0.0.0" newVersion="4.0.8.0" />
          </dependentAssembly>
        </assemblyBinding>
      </runtime>
    </configuration>
    Thanks.
  10. #10
    Thank you, but I am still unable to reproduce the problem.

    Maybe this technique can help to prepare a sample.
    How to prepare a sample

Similar Threads

  1. Replies: 3
    Last Post: Jan 09, 2012, 10:09 PM
  2. Crystal Report and Ext.net
    By sonlas7y20 in forum 1.x Help
    Replies: 7
    Last Post: Dec 29, 2011, 2:27 PM
  3. Crystal Report Viewer is not showing?
    By sadeque in forum 1.x Help
    Replies: 6
    Last Post: Nov 10, 2011, 3:43 PM
  4. Crystal Report Viewer Overlap
    By EzaBlade in forum 1.x Help
    Replies: 0
    Last Post: Sep 23, 2009, 1:26 PM
  5. How to add crystal report within panel
    By sadeque in forum 1.x Help
    Replies: 4
    Last Post: Jul 28, 2009, 5:57 AM

Tags for this Thread

Posting Permissions