SelectedRows of GridPanel does not work when RowSelectionModel is Multi.

  1. #1

    SelectedRows of GridPanel does not work when RowSelectionModel is Multi.

    <ext:GridPanel ID="gpRoleUsers" runat="server" ColumnWidth="0.7" Flex="1">
        <SelectionModel>
            <ext:RowSelectionModel ID="RowSelectionModel2" runat="server" Mode="Multi" />
        </SelectionModel>
    </ext:GridPanel>
    RowSelectionModel sm = gpRoleUsers.GetSelectionModel() as RowSelectionModel;
    foreach (SelectedRow row in sm.SelectedRows)
    {......}
    The problem is described as below:
    If the mode of RowSelectionModel is "Single", everything is OK. If the mode of RowSlectionModel is "Multi", I select one record at the first, then delete it, it's OK. And I select another record, then delete it again, the problem comes out. The selectedRows include 2 records (the current seleced record + the delete record).

    Attention: this problem only exists when the mode of RowSelectionModel is "Multi", and it will disapear when the mode of RowSelectionModel is "Single".

    Is this a bug or due to my code? Does anybody meet the same problem?
    Last edited by Santon_Lee; Dec 04, 2012 at 3:13 AM.

Similar Threads

  1. Replies: 2
    Last Post: Nov 29, 2012, 9:30 AM
  2. Replies: 1
    Last Post: Oct 16, 2012, 9:19 AM
  3. [CLOSED] How to get selectedrows of gridpanel
    By egvt in forum 1.x Premium Help
    Replies: 1
    Last Post: May 31, 2012, 7:10 PM
  4. Replies: 13
    Last Post: Mar 29, 2012, 2:39 PM
  5. Replies: 0
    Last Post: Dec 29, 2008, 8:19 AM

Tags for this Thread

Posting Permissions