Problems deploying on Server :Parser Error Message: An error occurred creating the configuration section handler for extnet: Cou

  1. #1

    Problems deploying on Server :Parser Error Message: An error occurred creating the configuration section handler for extnet: Cou

    My application worked perfectly on my development system but i am having serious issue deploying it on web server:
    The server is windows server 2008 R2. i am getting this error..



    Configuration Error
    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: An error occurred creating the configuration section handler for extnet: Could not load type 'Ext.Net.GlobalConfig'.

    Source Error:


    Line 2: <configuration>
    Line 3: <configSections>
    Line 4: <section name="extnet" type="Ext.Net.GlobalConfig" requirePermission="false"/>
    Line 5: </configSections>
    Line 6: <extnet scriptMode="Release" theme="Gray" />

    My web.config is:

    <?xml version="1.0"?>
    <configuration>
    <configSections>
    <section name="extnet" type="Ext.Net.GlobalConfig" requirePermission="false"/>
    </configSections>
    <extnet scriptMode="Release" theme="Gray" />

    <connectionStrings>
    <add name="globalcon" connectionString="Data Source=brooks;Initial Catalog=ManillaGlobal;Persist Security Info=True;User ID=sa;Password=Newlife1"
    providerName="System.Data.SqlClient" />
    <add name="datastorecon" connectionString="Data Source=brooks;Initial Catalog=mnlDatastore;Persist Security Info=True;User ID=sa;Password=Newlife1"
    providerName="System.Data.SqlClient" />
    <add name="workingcnstr" connectionString="Data Source=brooks;Initial Catalog=mnlWorkingdb;Persist Security Info=True;User ID=sa;Password=Newlife1"
    providerName="System.Data.SqlClient" />
    <add name="defaultcon" connectionString="Data Source=brooks;Initial Catalog=manillaLocal;Persist Security Info=True;User ID=sa;Password=Newlife1"
    providerName="System.Data.SqlClient" />
    <add name="reportcon" connectionString="Data Source=brooks;Initial Catalog=manillaReports;Persist Security Info=True;User ID=sa;Password=Newlife1"
    providerName="System.Data.SqlClient" />
    </connectionStrings>
    <appSettings>
    <add key="Telerik.Skin" value="Metro"/>
    </appSettings>
    <system.web>
    <compilation debug="true" targetFramework="4.0">
    <assemblies>
    <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
    <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
    <add assembly="System.Speech, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    <add assembly="ADODB, Version=7.0.3300.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
    <add assembly="System.Web.Extensions.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    <!--<add assembly="System.Web.Mvc, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    <add assembly="System.Web.WebPages, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />-->
    </assemblies>
    </compilation>
    <authentication mode="Forms">
    <forms loginUrl="~/Account/Login.aspx" timeout="2880" />
    </authentication>
    <membership>
    <providers>
    <clear />
    <add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="ApplicationServices" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="false" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" applicationName="/" />
    </providers>
    </membership>
    <profile>
    <providers>
    <clear />
    <add name="AspNetSqlProfileProvider" type="System.Web.Profile.SqlProfileProvider" connectionStringName="ApplicationServices" applicationName="/" />
    </providers>
    </profile>
    <roleManager enabled="false">
    <providers>
    <clear />
    <add name="AspNetSqlRoleProvider" type="System.Web.Security.SqlRoleProvider" connectionStringName="ApplicationServices" applicationName="/" />
    <add name="AspNetWindowsTokenRoleProvider" type="System.Web.Security.WindowsTokenRoleProvider " applicationName="/" />
    </providers>
    </roleManager>
    <httpHandlers>
    <add path="*/ext.axd" verb="*" type="Ext.Net.ResourceHandler" validate="false" />
    <add path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" verb="*" validate="false" />
    <add path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" validate="false" />
    <add path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false" />
    <add path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.RadUploadProgressHandler" verb="*" validate="false" />
    <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false" />
    </httpHandlers>
    <httpModules>
    <add name="DirectRequestModule" type="Ext.Net.DirectRequestModule, Ext.Net" />
    </httpModules>
    <pages>
    <controls>
    <add tagPrefix="ext" namespace="Ext.Net" assembly="Ext.Net" />
    <add tagPrefix="ajaxToolkit" assembly="AjaxControlToolkit" namespace="AjaxControlToolkit" />
    <add tagPrefix="telerik" namespace="Telerik.Web.UI" assembly="Telerik.Web.UI" />
    </controls>
    </pages>
    </system.web>
    <system.webServer>
    <modules runAllManagedModulesForAllRequests="true">
    <add name="DirectRequestModule" preCondition="managedHandler" type="Ext.Net.DirectRequestModule, Ext.Net" />
    </modules>
    <validation validateIntegratedModeConfiguration="false" />
    <handlers>
    <remove name="ChartImage_axd" />
    <remove name="Telerik_Web_UI_SpellCheckHandler_axd" />
    <remove name="Telerik_Web_UI_DialogHandler_aspx" />
    <remove name="Telerik_RadUploadProgressHandler_ashx" />
    <remove name="Telerik_Web_UI_WebResource_axd" />
    <add name="DirectRequestHandler" verb="*" path="*/ext.axd" preCondition="integratedMode" type="Ext.Net.ResourceHandler" />
    <add name="ChartImage_axd" path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" verb="*" preCondition="integratedMode" />
    <add name="Telerik_Web_UI_SpellCheckHandler_axd" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" preCondition="integratedMode" />
    <add name="Telerik_Web_UI_DialogHandler_aspx" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" preCondition="integratedMode" />
    <add name="Telerik_RadUploadProgressHandler_ashx" path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.RadUploadProgressHandler" verb="*" preCondition="integratedMode" />
    <add name="Telerik_Web_UI_WebResource_axd" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" preCondition="integratedMode" />
    </handlers>
    </system.webServer>

    <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
    <dependentAssembly>
    <assemblyIdentity name="Newtonsoft.Json" publicKeyToken="30ad4fe6b2a6aeed" />
    <bindingRedirect oldVersion="1.0.0.0-4.0.0.0" newVersion="4.0.8.0" />
    <bindingRedirect oldVersion="1.0.0.0-4.0.0.0" newVersion="4.5.7" />
    <assemblyIdentity name="Ext.Net.Utilities" publicKeyToken="2c34ac34702a3c23" />
    <bindingRedirect oldVersion="0.0.0.0-2.0.0" newVersion="2.0.1" />
    </dependentAssembly>
    <dependentAssembly>
    <assemblyIdentity name="AjaxControlToolkit" publicKeyToken="28f01b0e84b6d53e" culture="neutral" />
    <bindingRedirect oldVersion="0.0.0.0-4.1.60501.0" newVersion="4.1.60501.0" />
    </dependentAssembly>
    </assemblyBinding>
    </runtime>


    </configuration>

    I cant get any reasonable help anywhere.

    I dont know if i'm missing out any configuration option on the server or any dll. i have included all necessary dll in the bin folder..
    Attached Files
  2. #2
    Try to full qualify type
    type="Ext.Net.GlobalConfig, Ext.Net"
    and ensure that Ext.Net assembly is available on the server
    Vladimir Shcheglov
    Sr. Developer

Similar Threads

  1. Replies: 7
    Last Post: Aug 26, 2012, 8:13 AM
  2. Replies: 3
    Last Post: Jul 20, 2012, 4:19 PM
  3. [CLOSED] Error on deploying an MVC app
    By Stefanaccio in forum 1.x Premium Help
    Replies: 8
    Last Post: Oct 18, 2010, 12:12 AM
  4. Replies: 2
    Last Post: Sep 15, 2010, 9:38 AM
  5. A Runtime Error has occurred
    By mono in forum 1.x Help
    Replies: 1
    Last Post: Mar 11, 2009, 9:31 AM

Tags for this Thread

Posting Permissions