[CLOSED] EventStore AutoLoad=false not work?

  1. #1

    [CLOSED] EventStore AutoLoad=false not work?


    Maybe the autoload of EventStore, if false, is not working?

    Last edited by Daniil; Sep 03, 2012 at 5:12 PM. Reason: [CLOSED]
  2. #2

    Actually, it works. But the initially activated view initiates a load request.
  3. #3
    How can I avoid this behaviour and load events on demand?
  4. #4
    1. No active view.


    2. Override the Calendar JavaScript sources.

    The base class for all views is the Ext.calendar.view.AbstractCalendar one. There is the setStartDate function. If the third argument is true, the Store is reload. This method with true third argument is called within the Ext.calendar.CalendarPanel class. I think it might be difficult to override and don't break anything.


    3. Filter the events.

Similar Threads

  1. Store HttpProxy with AutoLoad = False
    By mkshields9w57 in forum 1.x Help
    Replies: 5
    Last Post: Oct 12, 2011, 5:07 PM
  2. Replies: 4
    Last Post: Feb 21, 2011, 10:02 PM
  3. [CLOSED] StoreBase.AutoLoad defaults to true but designer says false
    By SandorD in forum 1.x Legacy Premium Help
    Replies: 5
    Last Post: Mar 20, 2010, 1:50 PM
  4. [CLOSED] CheckboxSelectionModel Enabled=false does not work
    By macap in forum 1.x Legacy Premium Help
    Replies: 4
    Last Post: Sep 14, 2009, 10:09 AM
  5. Replies: 2
    Last Post: Mar 29, 2009, 3:20 PM

Posting Permissions