[CLOSED] TreePanel CSS Problem

  1. #1

    [CLOSED] TreePanel CSS Problem

    Hi,

    I appear to be getting some strange CSS conflict in my view with a TreePanel. When I click on an item in my grid (adjacent to the tree), a panel.update() fires with some HTML content (it's essentially an outlook-like 3 column webmail page, the tree being the folder list, grid being the email list and the panel being the preview pane).

    Click image for larger version. 

Name:	tree.jpg 
Views:	4 
Size:	4.2 KB 
ID:	4580

    As soon as I click on a message to preview it, my tree nodes all become underlined. Have you encountered something like this before? Is there a CSS rule I can apply to ensure it isn't getting overriden by something in the emails? The emails are pulled directly from Exchange, therefore they can be fully formed HTML pages with inline CSS.
    Last edited by Daniil; Aug 07, 2012 at 8:51 AM. Reason: [CLOSED]
  2. #2
    Hi,

    I have never met such issue before.

    Are the nodes configured with Href?

    Can you inspect nodes CSS to see the rule which makes them underlined? Maybe, it could clarify something.

    Any chance to get a sample to reproduce? We would do our best to investigate it.
  3. #3
    Quote Originally Posted by Daniil View Post
    Hi,

    I have never met such issue before.

    Are the nodes configured with Href?

    Can you inspect nodes CSS to see the rule which makes them underlined? Maybe, it could clarify something.

    Any chance to get a sample to reproduce? We would do our best to investigate it.
    Thank you, I think I've found the problem. Outlook creates custom CSS rules on HTML emails:

    a:link, span.MsoHyperlink {
        color: blue;
        text-decoration: underline;
    }
    .. I think this rule might be interfering with the treenode CSS. Firebug shows:

    Click image for larger version. 

Name:	css.jpg 
Views:	2 
Size:	6.3 KB 
ID:	4584

    .. though, the underline colour isn't blue it's black.

    EDIT: I've managed to disable the underline by addressing the rule quoted. Thanks for prompting me ;)

Similar Threads

  1. [CLOSED] [1.0] Treepanel click node problem with ie9
    By PoloTheMonk in forum 1.x Premium Help
    Replies: 2
    Last Post: Aug 13, 2012, 12:44 PM
  2. [CLOSED] [1.3] Problem with rootVisible on TreePanel
    By John_Writers in forum 1.x Premium Help
    Replies: 10
    Last Post: Apr 02, 2012, 7:46 AM
  3. [CLOSED] TreePanel Debug mode problem
    By asztern in forum 1.x Premium Help
    Replies: 2
    Last Post: Oct 19, 2010, 12:16 PM
  4. Problem with TreePanel Selection[1.0]
    By suchit_patel in forum 1.x Help
    Replies: 0
    Last Post: Jul 21, 2010, 8:38 AM
  5. treepanel removechildren problem
    By Richardt in forum 1.x Help
    Replies: 0
    Last Post: Oct 05, 2009, 10:56 AM

Tags for this Thread

Posting Permissions