[CLOSED] Slow loading of image from browser cache

  1. #1

    [CLOSED] Slow loading of image from browser cache

    Hi,

    I observed from Firebug that it takes 1+ second to load ext.net images from browser cache.
    Click image for larger version. 

Name:	Firebug Net Images.PNG 
Views:	115 
Size:	48.4 KB 
ID:	4271

    For the same web page, the css and js files are loaded very fast (< 100ms) from cache. I am in an intranet environment, Windows XP, Firefox 12. The website is hosted on IIS 6.0.

    Any hint that why this would happen? Let me know if you need more information. Your help is highly appreciated!
    Last edited by Daniil; May 28, 2012 at 5:56 PM. Reason: [CLOSED]
  2. #2
    Well, we cannot say anuthing concrete, browser retrieves resources from own cache, may be your HDD is overloaded or something else
    It is out of our competence
  3. #3
    Hi,

    My testing PC is quite a powerful new i5 machine. And I am sure that there was no heavy process running in the background when I run the test.

    I just did another test loading example.ext.net and I got something very similar:
    Click image for larger version. 

Name:	load_examples.ext.net.jpg 
Views:	74 
Size:	96.6 KB 
ID:	4333

    I observed that loading the same image from server is much father than loading from local cache (20 ms vs 1.5 sec). Any idea why is it so, are the ext images cached in server memory?

    Is there any way that caching can be turned off, i.e. force to load from server always? If yes, what might be the side-effects, besides much more http requests?

    Our application is really mission critical and this image loading time becomes the bottleneck now. Please help :)
  4. #4
    Do you see the same issue in all browsers? If deactivate FirebuG in Firefox then issue is still reproducible?
    Retrieving resources from cache is totalu under browser control, we cannot affect on this

    Is there any way that caching can be turned off, i.e. force to load from server always? If yes, what might be the side-effects, besides much more http requests?
    You can set CleanResourceUrl="false" in ResourceManager or in web.config. In this case, standard WebResource.axd will be used (it return resources without cache instrutions)

Similar Threads

  1. Replies: 3
    Last Post: Mar 19, 2013, 9:05 PM
  2. Page Loading very very slow
    By vs.mukesh in forum 1.x Help
    Replies: 8
    Last Post: Sep 24, 2012, 7:15 AM
  3. Init script in browser cache
    By moldeveloper in forum Feature Requests
    Replies: 1
    Last Post: Jun 08, 2012, 9:43 AM
  4. Browser does not cache resources after restart
    By nil5286 in forum 2.x Help
    Replies: 3
    Last Post: Apr 13, 2012, 4:27 PM
  5. Page Loading very slow
    By Rupesh in forum 1.x Help
    Replies: 0
    Last Post: Mar 25, 2011, 5:26 AM

Posting Permissions