ext.asd resource not found

  1. #1

    ext.asd resource not found

    Hi,

    I am trying to get a basic Ext.Net VS2010 project working using the Install and setup guide you have provided. However, when I run it, the EXT control does not get displayed. The source look like this:

    <html xmlns="http://www.w3.org/1999/xhtml">
        <head id="Head1">
    	<link rel="stylesheet" type="text/css" href="/WebResource.axd?d=wi1grsAc0CTjuO12wqC7XsNV_nf2RUrMwGaxtWqSgXv_Hjv9wGInX6efkmIGOqX8LuMuJKrHNJFHkWexUc2capVU_K00e_e0UenQL6iJmH4WF8UkXDARgbQ0X0vUOH6Yo2p5rtwg_f9quGMkwSKR-c9BGIqk5qhIX4qA3HZ6wJo1&amp;t=634469265286780655" />
    
    	<script type="text/javascript" src="/WebResource.axd?d=0WIxEu2sS1EtHyY8rlmGz9ncjd_IVF2B-LkFeBz68dr4sUAaPBgD5O_FzZuyimJgSzgouk1yVa-hr3Vl_fd1e6SrHQ-YmrUBlkg8DonziDmFyaMk87-3ht8bS9sbaayqY_jCtds09Ti68QuzV__8WDq1FJkf_JbWJLuC0vx1Yno1&amp;t=634469265286780655"></script>
    	<script type="text/javascript" src="/WebResource.axd?d=-IDaX46L5N8B-U6C6eIlHV1GuI6h9LKv7XIox43j3gL4K1yZzeufAspBNcHB5_bbK85-vXm5zFcPYaP5uZF-lui3cYjEl_t2jOJX5ud3ua8D3lpXPoF_QOmu6wLimSHRanUIHWPigFjRutExSNSb3Q2&amp;t=634469265286780655"></script>
    	<script type="text/javascript" src="/WebResource.axd?d=ZIj9TwWo8l0I9vcenqNkxcdfc3hwss6695sh5Sru7WVKRyzn5eLiEUxH9fjJzvnqQXo93NChOSmsS4EaJmTorWeiYx-4wcx8kC3mNISFv60wkFEJhqQoBt9OFf4-8Rqmamdtb09ElR6GsZy1uRuiNxAVzewKDP7PEXch6i3FDbE1&amp;t=634469265286780655"></script>
    
    	<script type="text/javascript" src="/extnet/extnet-init-js/ext.axd?854b6baab36c46c888d0f441f6a02cf1"></script>
    <title>
    
    </title></head>
    
        <body>
            <div id="CycleButton1_Container" style="display:inline;">
    	
    </div>
        </body>
    </html>
    And when I click on the line:

    /extnet/extnet-init-js/ext.axd?854b6baab36c46c888d0f441f6a02cf1

    This page is displayed:
    <html>
        <head>
            <title>The resource cannot be found.</title>
            <style>
             body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;} 
             p {font-family:"Verdana";font-weight:normal;color:black;margin-top: -5px}
             b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px}
             H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red }
             H2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon }
             pre {font-family:"Lucida Console";font-size: .9em}
             .marker {font-weight: bold; color: black;text-decoration: none;}
             .version {color: gray;}
             .error {margin-bottom: 10px;}
             .expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:hand; }
            </style>
        </head>
    
        <body bgcolor="white">
    
                <span><H1>Server Error in '/' Application.<hr width=100% size=1 color=silver></H1>
    
                <h2> <i>The resource cannot be found.</i> </h2></span>
    
                <font face="Arial, Helvetica, Geneva, SunSans-Regular, sans-serif ">
    
                <b> Description: </b>HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. &nbsp;Please review the following URL and make sure that it is spelled correctly.
                <br><br>
    
                <b> Requested URL: </b>/extnet/extnet-init-js/ext.axd<br><br>
    
                <hr width=100% size=1 color=silver>
    
                <b>Version Information:</b>&nbsp;Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.225
    
                </font>
    
        </body>
    </html>
    
    <!-- 
    [HttpException]: The controller for path '/extnet/extnet-init-js/ext.axd' was not found or does not implement IController.
       at System.Web.Mvc.DefaultControllerFactory.GetControllerInstance(RequestContext requestContext, Type controllerType)
       at System.Web.Mvc.DefaultControllerFactory.CreateController(RequestContext requestContext, String controllerName)
       at System.Web.Mvc.MvcHandler.ProcessRequestInit(HttpContextBase httpContext, IController& controller, IControllerFactory& factory)
       at System.Web.Mvc.MvcHandler.<>c__DisplayClass6.<BeginProcessRequest>b__2()
       at System.Web.Mvc.SecurityUtil.<>c__DisplayClassb`1.<ProcessInApplicationTrust>b__a()
       at System.Web.Mvc.SecurityUtil.<GetCallInAppTrustThunk>b__0(Action f)
       at System.Web.Mvc.SecurityUtil.ProcessInApplicationTrust(Action action)
       at System.Web.Mvc.SecurityUtil.ProcessInApplicationTrust[TResult](Func`1 func)
       at System.Web.Mvc.MvcHandler.BeginProcessRequest(HttpContextBase httpContext, AsyncCallback callback, Object state)
       at System.Web.Mvc.MvcHandler.BeginProcessRequest(HttpContext httpContext, AsyncCallback callback, Object state)
       at System.Web.Mvc.MvcHandler.System.Web.IHttpAsyncHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData)
       at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
    -->
    COuld you please help me fix this problem.


    Thanks
    Ram
  2. #2
    Hi,

    Please check your Global.asax
    It should contains
    public class MvcApplication : System.Web.HttpApplication
        {
            protected void Application_AuthenticateRequest(object sender, System.EventArgs e)
            {
                string url = HttpContext.Current.Request.FilePath;
                if (url.EndsWith("ext.axd"))
                {
                    HttpContext.Current.SkipAuthorization = true;
                }
                else if (url.Contains("returnurl=/default.aspx") || url.Contains("returnurl=%2fdefault.aspx"))
                {
                    Response.Redirect(url.Replace("returnurl=/default.aspx", "r=/").Replace("returnurl=%2fdefault.aspx", "r=/"));
                }
            } 
    
    
            public static void RegisterRoutes(RouteCollection routes)
            {
                routes.IgnoreRoute("{resource}.axd/{*pathInfo}");
    
    
                routes.IgnoreRoute("{exclude}/{extnet}/ext.axd");
    
    
                routes.MapRoute(
                    "Default",                                              // Route name
                    "{controller}/{action}/{id}",                           // URL with parameters
                    new { controller = "Home", action = "Index", id = "" }  // Parameter defaults
                );
    
    
                /**/
    
    
                routes.MapRoute(
                  "Default2",
                  "{controller}.mvc/{action}/{id}",
                  new { action = "Index", id = "" }
                );
    
    
                routes.MapRoute(
                  "Root",
                  "",
                  new { controller = "Home", action = "Index", id = "" }
                );
            }
    Vladimir Shcheglov
    Sr. Developer
  3. #3
    Hi,
    I have the same issue:

    Can you look at my link below:
    http://forums.ext.net/showthread.php...7634#post77634

    I imported:
    .cs
    using System.Web.Routing;
    But I can see the property IgnoreRoute
    Example:
    // routes.IgnoreRoute("{exclude}/{extnet}/ext.axd");

    Quote Originally Posted by Vladimir View Post
    Hi,

    Please check your Global.asax
    It should contains
    public class MvcApplication : System.Web.HttpApplication
        {
            protected void Application_AuthenticateRequest(object sender, System.EventArgs e)
            {
                string url = HttpContext.Current.Request.FilePath;
                if (url.EndsWith("ext.axd"))
                {
                    HttpContext.Current.SkipAuthorization = true;
                }
                else if (url.Contains("returnurl=/default.aspx") || url.Contains("returnurl=%2fdefault.aspx"))
                {
                    Response.Redirect(url.Replace("returnurl=/default.aspx", "r=/").Replace("returnurl=%2fdefault.aspx", "r=/"));
                }
            } 
    
    
            public static void RegisterRoutes(RouteCollection routes)
            {
                routes.IgnoreRoute("{resource}.axd/{*pathInfo}");
    
    
                routes.IgnoreRoute("{exclude}/{extnet}/ext.axd");
    
    
                routes.MapRoute(
                    "Default",                                              // Route name
                    "{controller}/{action}/{id}",                           // URL with parameters
                    new { controller = "Home", action = "Index", id = "" }  // Parameter defaults
                );
    
    
                /**/
    
    
                routes.MapRoute(
                  "Default2",
                  "{controller}.mvc/{action}/{id}",
                  new { action = "Index", id = "" }
                );
    
    
                routes.MapRoute(
                  "Root",
                  "",
                  new { controller = "Home", action = "Index", id = "" }
                );
            }

Similar Threads

  1. Replies: 1
    Last Post: Apr 16, 2013, 3:06 AM
  2. Failed to load resource
    By tuananhdnx in forum 1.x Help
    Replies: 3
    Last Post: Dec 27, 2011, 1:26 PM
  3. How do you add a resource item
    By craig2005 in forum 1.x Premium Help
    Replies: 6
    Last Post: Feb 09, 2011, 6:44 PM
  4. All the Embeded Resource should be 304 quickly
    By sipo in forum Feature Requests
    Replies: 10
    Last Post: Aug 26, 2010, 7:50 PM
  5. Icon resource
    By Yannis in forum 1.x Help
    Replies: 1
    Last Post: Jun 22, 2010, 4:02 AM

Posting Permissions