[CLOSED] Item disable style stopped working

  1. #1

    [CLOSED] Item disable style stopped working

    It seems to me that after the upgrade to 2.x, some styles have stopped working

    I have in my css

    .x-item-disabled input {
        color: #C6C6C6 !important;
    }
    In my combobox, I set DisabledClass="x-item-disable"


    I link the css file this way

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head runat="server">
        <title>Sugestões</title>
        <link href="~/Resources/Styles/SuperaWeb.css" rel="stylesheet" type="text/css" />
        <link href="~/Resources/Styles/ExtNet.css" rel="stylesheet" type="text/css" />
    </head>
    Last edited by Daniil; Jan 24, 2012 at 6:51 AM. Reason: [CLOSED]
  2. #2
    Hi,

    The following sample appears to function correctly.

    Example

    <%@ Page Language="C#" %>
    
    <%@ Register Assembly="Ext.Net" Namespace="Ext.Net" TagPrefix="ext" %>
    
    
    <!DOCTYPE html>
      
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head runat="server">
        <title>Ext.NET Example</title>
    
    
        <link href="example.css" rel="stylesheet" type="text/css" />
    
    
        <%--
        <style type="text/css">
            .x-item-disabled input {
                color : #f00 !important;
            }
        </style>
        --%>
    </head>
    <body>
    <form runat="server">
        <ext:ResourceManager runat="server" />
    
    
        <ext:ComboBox runat="server" Disabled="true" Text="Hello World" />
    </form>
    </body>
    </html>
    If this issue is still an issue, please post a simplified code sample which demonstrates how to reproduce.
    Geoffrey McGill
    Founder & CEO
  3. #3
    Hi Geoffrey... thank you for your response.

    I wish that the FieldLabel stay in black color, like other fields, when it is disable...

    I create a single exemple, without a Css file, and did not change a Fieldlabel color also...

    I teste this code in IE, Firefox, Google Chrome and Opera, with the same result.

    Follow:

    <%@ Page Language="C#" %>
    <%@ Register Assembly="Ext.Net" Namespace="Ext.Net" TagPrefix="ext" %> 
    
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" 
        "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head id="Head1" runat="server">
        <title>Ext.NET Example</title>
        
        <style type="text/css">
            .x-item-disabled input {
                color : Black !important;
            }    
        </style>
    
    </head>
    <body>
        <form id="Form1" runat="server">
            <ext:ResourceManager ID="ResourceManager1" runat="server" />
            <ext:TextField runat="server" ID="txtNome" FieldLabel="teste" Disabled="true"/>
        </form>
    </body>
    </html>
  4. #4
    Hi @supera,

    Please apply:
    <style type="text/css">
        .x-item-disabled {
            opacity: 1;
            filter: alpha(opacity=100);
        }
    </style>
    It works almost 100% apart from a text color of input HTML element in IE - it's gray. IE manages CSS of disabled input HTML elements itself on a browser level, therefore, unfortunately, there is no way to override it.
  5. #5
    Hi Daniil

    Thanks for your responde

    I test your exemple and this working fine! Improved somewhat the presentation of the disabled fields.

    Too bad the code below no work in version 2.x. .. worked well in version 1.x

    .x-item-disabled input {
        color: Black !important;
    }
  6. #6
    Many CSS classes names, rules have been changed in Ext.NET v2 / ExtJS 4 in optimization purpose.

Similar Threads

  1. Replies: 12
    Last Post: Jul 25, 2011, 2:25 PM
  2. Replies: 19
    Last Post: Apr 27, 2011, 7:26 PM
  3. Ext.Net.ResourceBuilder stopped working
    By purvi in forum 1.x Help
    Replies: 0
    Last Post: Sep 22, 2010, 9:52 PM
  4. [CLOSED] VBoxlayout Stopped Working after SVN update
    By SymSure in forum 1.x Premium Help
    Replies: 8
    Last Post: Mar 23, 2010, 3:17 PM
  5. EventMasks stopped working
    By EzaBlade in forum 1.x Help
    Replies: 5
    Last Post: Mar 24, 2009, 6:21 PM

Posting Permissions