Using v1.2, FieldSet Render fine locally on Server 2008 IE 8.0, but NOT when browsing from client IE 8.0, it works in FireFox!!!

Page 1 of 3 123 LastLast
  1. #1

    Using v1.2, FieldSet Render fine locally on Server 2008 IE 8.0, but NOT when browsing from client IE 8.0, it works in FireFox!!!

    I'm using FieldSet below:
            <ext:FieldSet ID="FieldSetTop" runat="server" StyleSpec="padding-left: 5px;" Title="Period Entry"
                BodyStyle="background-color:Transparent;" Layout="ColumnLayout">
                <Items>
                    <ext:NumberField ID="PeriodDoughType" runat="server" Text="0" Cls="numberTop" LabelAlign="Top"
                        FieldLabel="<h3># of Dough Types<br>(Wkly Avg)" AllowBlank="false" />
                    <ext:NumberField ID="PeriodFGItems" runat="server" Text="0" Cls="numberTop" LabelAlign="Top"
                        FieldLabel="<h3># of FG Items<br>(Wkly Avg)" AllowBlank="false"/>
                    <ext:NumberField ID="PeriodLines" runat="server" Text="0" Cls="numberTop" LabelAlign="Top"
                        FieldLabel="<h3><br># of Lines" AllowBlank="false"/>
                    <ext:NumberField ID="PeriodPlanTypes" runat="server" Text="0" Cls="numberTop" LabelAlign="Top"
                        FieldLabel="<h3><br># of Plan Types" AllowBlank="false"/>
                    <ext:NumberField ID="PeriodRunHrs" runat="server" Text="0" Cls="numberTop" LabelAlign="Top"
                        FieldLabel="<h3>Theor. Run Hrs<br> at wrapper" AllowBlank="false"/>
                    <ext:NumberField ID="PeriodTransportTrips" runat="server" Text="0" Cls="numberTop" LabelAlign="Top"
                        FieldLabel="<h3>Transport<br>Trips" AllowBlank="false"/>
                    <ext:NumberField ID="PeriodUnAccountedProducts" runat="server" Text="0" Cls="numberTop" LabelAlign="Top"
                        FieldLabel="<h3>Product<br>Unaccounted For $" AllowBlank="false"/>
                </Items>
            </ext:FieldSet>
    When I run it locally on Server 2008 IIS 7.5 IE8.0, it Renders fine, but when when a client browse it from IE 8.0 it throw off the style and textes are not formatted properly...

    But it renders perfect in FireFox...
    Please help, I have a demo at 2PM today and the clients ONLY has IE 7.0 - IE 8.0 !!!
  2. #2
    Hi,

    What about the resources requests? Are they all loaded correctly?

    What is a server a site hosted on? IIS? What is the version?
  3. #3
    All the resources seems to be loaded correctly, how would I know if they won't loaded correctly ??

    I had to move the Application to a differents SERVER, from 2008 - 2003 box, same behaviour !!!

    Server a site hosted on: Microsoft Windows Server 2003
    Web Edition
    Service Pack 2

    IIS: V6.0

    IE 7.0 (version 7.0.5730.13)

    PS.
    I have other applications running the v1.2 Ext.NET dlls on this 2003 Server and it works fine !!!
  4. #4

    Image

    Image attached


    Click image for larger version. 

Name:	Not rendered properly from Server 2003.jpg 
Views:	111 
Size:	99.3 KB 
ID:	3744
  5. #5
    Renders properly when running locally.

    Click image for larger version. 

Name:	Renders properly when running locally.jpg 
Views:	111 
Size:	94.7 KB 
ID:	3745
  6. #6

    I had my MANAGER purchase 5 PRO Licenses !!!! Really need help guys, please...

    Our environment is intranet an users are ONLY allow to use IE....

    I have deadlines and your products Ext.NET v1.2 is not rendering correctly on IE 7.0/8.0 on Both Windows Server 2003 & 2008 !!!! (I hava attached Screen shots previously)

    Previous version Ext.NET v0.8 is running on TEST servers and works fine, we purchased 5 Pro Licenses and now the NEW product has issues and I need help to get it resolved.

    PLEASE HELP US !!!!
  7. #7
    Quote Originally Posted by RonaldR View Post
    All the resources seems to be loaded correctly, how would I know if they won't loaded correctly ??
    Checking it via browser's IE9 Developer Tools or Fiddler for IE.

    Your problem looks as a cross-browser one.

    Could you provide a simplified .aspx code sample which demonstrates how we can reproduce the issues?
    Last edited by geoffrey.mcgill; Jan 21, 2012 at 3:34 PM.
  8. #8
    Hi RonaldR,

    In your original sample, it appears you are not closing your <h3> tags. The following revision should be made to all affected .FieldLabel properties.

    Example

    // Existing
    FieldLabel="<h3># of Dough Types<br>(Wkly Avg)"
    
    // Revised
    FieldLabel="<h3># of Dough Types<br />(Wkly Avg)</h3>"
    Please note the correctly revised self-closing syntax for the <br /> as well.

    All the browsers are going to handle unclosed tags differently... generally with unexpected results.

    Hope this helps.
    Geoffrey McGill
    Founder
  9. #9
    Guys,
    I tried your suggestions, but it still DID NOT work for me!!!

    So I have decided to remove everything in my UserControl.ascx except the panel, take a look, same effect !!!

    I have two screen shots below, one rendering properly when running locally on VS '08 and one running local on Server 2003 as I described before...

    .ascx
    <%@ Control Language="C#" AutoEventWireup="true" CodeBehind="Weekly.ascx.cs" Inherits="Web.UserControls.Weekly" %>
    <ext:Panel ID="WeeklyPanelMain" runat="server" Layout="Form">
        <Items>
            <ext:Panel ID="WeeklyPanelSub" runat="server" Layout="ColumnLayout">
                <Items>
                    <ext:NumberField ID="WeeklyNumberOfOSHARecordableCases" runat="server" Text="0" LabelAlign="Top"
                        FieldLabel="Cases" AllowBlank="false" />
                    <ext:NumberField ID="WeeklyNetUnitsWrapped" runat="server" Text="0" LabelAlign="Top"
                        FieldLabel="Wrapped (Lbs)" AllowBlank="false" />
                    <ext:NumberField ID="WeeklyTheoreticalRunHoursAtWrapper" runat="server" Text="0"
                     LabelAlign="Top" FieldLabel="Theoretical Run" AllowBlank="false" />
                    <ext:NumberField ID="WeeklyTotalIngredientsUsedWeight" runat="server" Text="0" LabelAlign="Top"
                        FieldLabel="Total Ingredients" AllowBlank="false" />
                    <ext:NumberField ID="WeeklyActualChangeoverHoursAtWrapper" runat="server" Text="0"
                        LabelAlign="Top" FieldLabel="Actual Changeover" AllowBlank="false" />
                    <ext:NumberField ID="WeeklyInventoryVariance" runat="server" Text="0" LabelAlign="Top"
                        FieldLabel="Inventory Variance" AllowBlank="false" />
                    <ext:NumberField ID="WeeklyProductUnaccounted" runat="server" Text="0" LabelAlign="Top"
                        FieldLabel="Unaccounted For $" AllowBlank="false" />
                </Items>
            </ext:Panel>
        </Items>
    </ext:Panel>

    Click image for larger version. 

Name:	Renders properly when running locally.JPG 
Views:	97 
Size:	54.8 KB 
ID:	3752

    Click image for larger version. 

Name:	Not rendered properly from Server 2003.jpg 
Views:	87 
Size:	93.7 KB 
ID:	3753
  10. #10
    Not sure if this matters, but I'm using Layout="card" in my calling page like below:

    .aspx
    <%@ Register Src="~/UserControls/Weekly.ascx" TagName="Weekly" TagPrefix="uc" %>
    
        <ext:Panel ID="WizardPanel" runat="server" Title="Sara Lee Data Entry (all fields required)"
            PaddingSummary="15px 15px 0px 15px" Height="490" Layout="card" ActiveIndex="0"
            Border="true">
    And one item is the Usercontrol which I stated earlier...
            <Items>
                <ext:Panel ID="Panel3" runat="server" Border="false" Header="false">
                    <Content>
                        <uc:Weekly ID="Weekly" runat="server" />
                    </Content>
                    <Listeners>
                        <BeforeShow Handler="tbDisplay.show(); btnClear.show(); btnSave.show();" />
                    </Listeners>
                </ext:Panel>
            </Items>
Page 1 of 3 123 LastLast

Similar Threads

  1. Replies: 24
    Last Post: Aug 06, 2012, 12:26 PM
  2. Replies: 0
    Last Post: Jun 22, 2011, 2:52 PM
  3. Replies: 3
    Last Post: Jun 04, 2011, 10:23 AM
  4. Replies: 0
    Last Post: Feb 17, 2010, 1:25 PM
  5. Replies: 8
    Last Post: Jan 20, 2010, 10:38 PM

Posting Permissions