[CLOSED] IIS7 Windows 7 x Windows 2008

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    [CLOSED] IIS7 Windows 7 x Windows 2008

    I have my application published on a Windows 2008 Server and is running perfectly.

    But I had to publish a new station in Windows 7 Professional, both with IIS 7.
    But at the station with W7 is giving the following error:

    Detalhes dos erros da página da Web

    Agente de Usuário: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; InfoPath.1)
    Carimbo de data/hora: Mon, 7 Nov 2011 17:21:48 UTC


    Mensagem: 'parent.Ext.getCmp(...)' é nulo ou não é um objeto
    Linha: 279
    Caractere: 134
    Código: 0
    URI: http://siscanhomrh/SisproV50/extnet/...xt.axd?v=31626


    Any suggestions?

    My WebConfig

    <?xml version="1.0" encoding="UTF-8"?>
    <!--
      For more information on how to configure your ASP.NET application, please visit
      http://go.microsoft.com/fwlink/?LinkId=169433
      -->
    <configuration>
        <configSections>
        <!-- Add "extnet" configuration section to Web.config -->
        <section name="extnet" type="Ext.Net.GlobalConfig" requirePermission="false" />
        </configSections>
      <!-- "licenseKey" config -->
      <extnet licenseKey=".............................." />
    
      <!--<extnet scriptMode="Release"/>-->
        <system.web>
        <sessionState timeout="60" />
        <pages validateRequest="false" />
            <httpModules>
                <add name="DirectRequestModule" type="Ext.Net.DirectRequestModule, Ext.Net" />
            </httpModules>
            <httpHandlers>
                <add path="*/ext.axd" verb="*" type="Ext.Net.ResourceHandler" validate="false" />
          <add verb="GET" path="CrystalImageHandler.aspx" type="CrystalDecisions.Web.CrystalImageHandler, CrystalDecisions.Web, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304" />
            </httpHandlers>
            <compilation targetFramework="4.0" debug="true">
                <assemblies>
                    <add assembly="System.Web.Routing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
                    <add assembly="System.Web.Extensions.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
                    <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
                    <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" /></assemblies>
            </compilation>
            <!--
                The <authentication> section enables configuration 
                of the security authentication mode used by 
                ASP.NET to identify an incoming user. 
            -->
            <authorization>
                <deny users="?" />
            </authorization>
            <authentication mode="Forms">
                <forms loginUrl="~/Default.aspx" timeout="800"></forms>
            </authentication>
            <identity impersonate="true" />
        </system.web>
        <system.webServer>
            <validation validateIntegratedModeConfiguration="false" />
            <modules>
                <add name="DirectRequestModule" preCondition="managedHandler" type="Ext.Net.DirectRequestModule, Ext.Net" />
            </modules>
            <handlers>
                <add name="DirectRequestHandler" verb="*" path="*/ext.axd" preCondition="integratedMode" type="Ext.Net.ResourceHandler" />
          <add name="CrystalImageHandler.aspx_GET" verb="GET" path="CrystalImageHandler.aspx" type="CrystalDecisions.Web.CrystalImageHandler, CrystalDecisions.Web, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304" preCondition="integratedMode" />
            </handlers>
            <defaultDocument>
                <files>
                    <clear />
                    <add value="default.aspx" />
                    <add value="Default.htm" />
                    <add value="Default.asp" />
                    <add value="index.htm" />
                    <add value="index.html" />
                    <add value="iisstart.htm" />
                </files>
            </defaultDocument>
        </system.webServer>
        <location path="Contents">
            <system.web>
                <authorization>
                    <allow users="*" />
                    <!-- Allows all users -->
                </authorization>
            </system.web>
        </location>
        <location path="Error">
            <system.web>
                <authorization>
                    <allow users="*" />
                    <!-- Allows all users -->
                </authorization>
            </system.web>
        </location>
    </configuration>
    Last edited by Daniil; Nov 10, 2011 at 8:39 PM. Reason: [CLOSED]
  2. #2
    Hi,

    I guess the Ext.Net resources are not loaded.

    Please check the resources requests.
  3. #3
    Quote Originally Posted by Daniil View Post
    Hi,

    I guess the Ext.Net resources are not loaded.

    Please check the resources requests.
    What resources?

    Why can not open the pages and controls are displayed correctly.

    But when using this feature is generated the error.
  4. #4
    Hi,

    Is your Window 7 x64?
    If yes then you have to set Classic application pool in IIS
  5. #5
    Quote Originally Posted by Vladimir View Post
    Hi,

    Is your Window 7 x64?
    If yes then you have to set Classic application pool in IIS
    It is a 32-bit W7
    And I'm using Classic application pool in IIS
  6. #6
    We have no 'parent.Ext.getCmp' in our scripts. I guess it is your script. Please provide test sample causes that error

Similar Threads

  1. Replies: 4
    Last Post: Mar 04, 2011, 3:36 PM
  2. Ext.NET on windows server 2008 64bits
    By luchexrb in forum 1.x Help
    Replies: 1
    Last Post: Mar 04, 2011, 3:14 PM
  3. Installation problems, Windows 7 x64 IIS7
    By paul-2011 in forum 1.x Help
    Replies: 9
    Last Post: Jun 24, 2010, 1:41 PM
  4. [CLOSED] Desktop BUG: Modal windows can be minimized and you can interact with the other windows
    By juanpablo.belli@huddle.com.ar in forum 1.x Legacy Premium Help
    Replies: 2
    Last Post: Mar 31, 2009, 3:49 PM
  5. Replies: 1
    Last Post: Mar 29, 2008, 8:04 PM

Posting Permissions