[CLOSED] MenuAlign issue in Internet Explorer

  1. #1

    [CLOSED] MenuAlign issue in Internet Explorer

    Hi,

    When using MenuAlign on a button with a menu that opens when you click it, in Internet Explorer the menu initially opens aligned to the wrong place. Subsequent clicks of the button open the menu in the correct place.

    Example:

    <!DOCTYPE html>
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head runat="server">
        <title></title>
    </head>
    <body>
        <form runat="server">
            <ext:ResourceManager runat="server" />
    
            <ext:CompositeField runat="server">
                <Items>
                    <ext:DisplayField runat="server" Width="300" />
                    <ext:Button runat="server" MenuAlign="tr-br?">
                        <Menu>
                            <ext:Menu runat="server">
                                <Items>
                                    <ext:FormPanel runat="server">
                                        <Items>
                                            <ext:TextField runat="server" />
                                        </Items>
                                    </ext:FormPanel>
                                </Items>
                            </ext:Menu>
                        </Menu>
                    </ext:Button>
                </Items>
            </ext:CompositeField>
        </form>
    </body>
    </html>
    Steps to reproduce:

    1. Load example in Internet Explorer
    2. Click on button

    You will see that the menu opens to the bottom right.

    3. Click elsewhere to close menu
    4. Click on button

    You will see that the menu now opens in the correct place, to the bottom left.

    Thanks
    Last edited by geoffrey.mcgill; Sep 28, 2011 at 3:57 AM. Reason: [CLOSED]
  2. #2
    IE cannot determine correct width of menu until first show
    To fix it please set fixed width for FormPanel (for example, Width="250")
    Vladimir Shcheglov
    Sr. Developer
  3. #3
    Another fix/workaround can be this menu Show listener.
    <Show Handler="Button1.showMenu();" Single="true" />

Similar Threads

  1. [CLOSED] ViewPort Internet Explorer bug
    By boris in forum 2.x Legacy Premium Help
    Replies: 2
    Last Post: Feb 28, 2012, 12:01 PM
  2. [CLOSED] Internet Explorer 9 compatibility
    By SandorD in forum 1.x Legacy Premium Help
    Replies: 7
    Last Post: Mar 21, 2011, 9:00 AM
  3. [CLOSED] el.setSize Issue Internet Explorer
    By tjbishop in forum 1.x Legacy Premium Help
    Replies: 8
    Last Post: Sep 10, 2010, 6:20 PM
  4. [CLOSED] internet explorer cannot open the internet site
    By speedstepmem4 in forum 1.x Legacy Premium Help
    Replies: 3
    Last Post: Apr 28, 2009, 10:30 AM
  5. Internet Explorer 8
    By Ben in forum Open Discussions
    Replies: 3
    Last Post: Feb 25, 2009, 12:38 AM

Posting Permissions