[CLOSED] Strange error after compile last svn update

  1. #1

    [CLOSED] Strange error after compile last svn update

    I updated from svn today and after compile project using the Ext.Net.2008.sln solution file. I got the error in my projects

    Error 1 Assembly 'ERP.Components, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' uses 'Ext.Net, Version=1.0.4161.19916, Culture=neutral, PublicKeyToken=2e12ce3d0176cd87' which has a higher version than referenced assembly 'Ext.Net, Version=1.0.0.24454, Culture=neutral, PublicKeyToken=2e12ce3d0176cd87' z:\erp.net\fontes\ERP.Components\bin\Debug\ERP.Com ponents.dll ERP.Net

    Things I've done to try solve this problem.

    >I changed all references to new ext.net.dll;
    >put assembly redirecting on app.config


    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
                <dependentAssembly>
                    <assemblyIdentity name="Ext.Net" culture="neutral"/>
                    <bindingRedirect oldVersion="0.0.0.0-1.0.4161.19916" newVersion="1.0.0.24454"/>
                </dependentAssembly>
            </assemblyBinding>
    > change the "Copy Local" property to true/false;
    > change "Specific Version"property to true/false;

    I'm using VS2008/C# ASP.Net

    Someone can help me with this error?

    Thanks.
    Last edited by Daniil; Jun 28, 2011 at 1:32 PM. Reason: [CLOSED]
  2. #2
    Hi,

    Just delete all old Ext.Net reference in ERP.Components project (from project and web.config)
    After that add reference to new assembly
  3. #3
    Hi,
    I tried to do this before. But not works too. The problem is the
    ERP.Component is a dll, the ERP.Net is a dll too and one depends on the other and both depends on ext.net.dll.
  4. #4
    Hi,

    That dlls (ERP.Component.dll and ERP.Net.dll) must be build with the latest Ext.Net dlls you want to use.
  5. #5
    I've done that too and hadn't solved.
    But that's okay.

    What I did to solve the problem:

    My dll base is the erp.net.dll, so I removed all the references that were in erp.components, including ext.net .*.
    I Recreated the erp.components.dll without references to ext.net.dll. Using erp.net.dll as reference only.
    Erp.components compiled fine, so I began to remake erp.net.dll using the new version of ext.net.dll.

    was a workaround, but solved the problem.
    In future versions I don't have to worry about this because the only dll that references to Ext.Net.dll is ERP.Net.dll.

    Thanks for the tips :)
  6. #6
    Thanks for the details. It can help someone in the future.

Similar Threads

  1. Ext.Net.Desktop compile error
    By Mahi in forum 1.x Help
    Replies: 1
    Last Post: Apr 25, 2012, 9:24 PM
  2. Ext.net.Desktop compile error
    By Mahi in forum 2.x Help
    Replies: 1
    Last Post: Apr 25, 2012, 7:48 PM
  3. [CLOSED] Error compile .Net Framework 4
    By majunior in forum 1.x Legacy Premium Help
    Replies: 4
    Last Post: Apr 26, 2011, 8:03 PM
  4. [CLOSED] [1.0] Ext.Net.Field.SetValue compile error
    By egodoy in forum 1.x Legacy Premium Help
    Replies: 2
    Last Post: May 13, 2010, 4:25 PM
  5. [CLOSED] Compile error on build 1331
    By Jurke in forum 1.x Legacy Premium Help
    Replies: 2
    Last Post: Apr 22, 2009, 9:28 AM

Posting Permissions