[CLOSED] Problem opening multiple tabpanels the same time.

Page 6 of 6 FirstFirst ... 456
  1. #51
    Quote Originally Posted by Vladimir View Post
    Hi,

    If you add some delay to the Page_Load of tab pages then is the problem reproducible on the local machine?
    protected void Page_Load(object sender, EventArgs e)
    {
         System.Threading.Thread.Sleep(5000);
    }
    Sleep With the problem continues
  2. #52
    Hi,

    Please provide more details, if you add Sleep then the issue is reproduciable on both servers (remote (IIS) and local)? Correct?
    Vladimir Shcheglov
    Sr. Developer
  3. #53
    Quote Originally Posted by Vladimir View Post
    Hi,

    Please provide more details, if you add Sleep then the issue is reproduciable on both servers (remote (IIS) and local)? Correct?
    Running the debugger in VS2010 the problem does not happen.
    But if I publish in my IIS the problem is played.
  4. #54
    1. Please simplify the online sample as much as you can using this technique:
    How to reduce a sample

    2. Add LayoutOnTabChange="true" and HideMode="Offsets" for the TabPanel.

    3. Remove TaskManager. I believe it's not required to reproduce? but causing multiple errors on our side. By the way why do you make a request every second? It's too hard for server.

    We are waiting the modified online sample.
  5. #55
    Quote Originally Posted by Daniil View Post
    1. Please simplify the online sample as much as you can using this technique:
    How to reduce a sample

    2. Add LayoutOnTabChange="true" and HideMode="Offsets" for the TabPanel.

    3. Remove TaskManager. I believe it's not required to reproduce? but causing multiple errors on our side. By the way why do you make a request every second? It's too hard for server.

    We are waiting the modified online sample.
    This is the address of the simplest structure that I could play http://189.114.146.15/demoext

    But when I access this externally from another network address the problem is not reproduced.

    If I access my localhost machine / demoext the problem is NOT playing.
    If I access my machine majunior / demoext the problem is played.

    Follow the attached project, please rename the. txt to. puplic in your zip and iis.

    You must quickly click on item1 then item2
    If you slow the problem is not the case.
    Then click on item1 and you will see that the page was not loaded from item1.


    If you want I can record a video showing how I'm running.
  6. #56
    Hi,

    Can you post a screenshot how the issue is look for your last online sample?
    Vladimir Shcheglov
    Sr. Developer
  7. #57
    Quote Originally Posted by Vladimir View Post
    Hi,

    Can you post a screenshot how the issue is look for your last online sample?
    image1.jpg - When I open the application
    image2.jpg - after clicking and clicking item1 item2 (clicks should be quick)
    imagem3.JPG - after clicking on the item1 treeview (you can see that the buttom does not appear)
    imagem4.JPG - if I click on any position on the screen the page is assembled correctly and the button appears.
  8. #58
    I reproduced the issue under IE7 and IE9 + standard IE7 mode.

    So, I guess, there is Compatibility mode in the IE8 that you use to test under.

    Please note that Compatibility mode is not officially supported.

    To fix it for IE7 (and, probably, for compatibility mode) please add this TabChange listener for the TabPanel:
    <TabChange Handler="var frame = tab && tab.getBody()
                            body = frame && frame.Ext && frame.Ext.getBody();
                        if (body) {
                            body.repaint();
                        }" />
  9. #59
    Quote Originally Posted by Daniil View Post
    I reproduced the issue under IE7 and IE9 + standard IE7 mode.

    So, I guess, there is Compatibility mode in the IE8 that you use to test under.

    Please note that Compatibility mode is not officially supported.

    To fix it for IE7 (and, probably, for compatibility mode) please add this TabChange listener for the TabPanel:
    <TabChange Handler="var frame = tab && tab.getBody()
                            body = frame && frame.Ext && frame.Ext.getBody();
                        if (body) {
                            body.repaint();
                        }" />
    Thank you, I managed to solve the problem as well.
Page 6 of 6 FirstFirst ... 456

Similar Threads

  1. opening severall time a desktop window
    By feanor91 in forum 1.x Help
    Replies: 4
    Last Post: Dec 22, 2011, 11:49 AM
  2. [CLOSED] Problem opening a popoup window
    By sisa in forum 1.x Premium Help
    Replies: 5
    Last Post: Dec 15, 2011, 12:31 PM
  3. Replies: 4
    Last Post: Sep 26, 2011, 3:42 AM
  4. [CLOSED] Problem with focus and tabpanels under IE9
    By Pablo_Azevedo in forum 1.x Premium Help
    Replies: 11
    Last Post: Jun 14, 2011, 4:42 PM
  5. [CLOSED] Problem with GridPanel BottomBars on a TabPanels
    By asztern in forum 1.x Premium Help
    Replies: 2
    Last Post: Dec 22, 2010, 3:11 PM

Posting Permissions