PDA

View Full Version : Connecting to SVN server



kiran malgi
Aug 03, 2010, 5:57 AM
Hi all..

we have purchased New ext.net and we have got this links to the SVN location with user name and password...

my problem is when we browse these links (

Coolite.EmbeddedResourceBuilder/
Coolite.Examples/
Coolite.Ext.UX/
Coolite.Ext.Web/
Coolite.Sandbox/
Coolite.Toolkit.install.sln
Coolite.Toolkit.sln
Coolite.Utilities/

) it will show some other links and if we lick on that it is showing source code
which i can't understand..and till now we didn't get .dll, please help soon i want to do some experiments on my project with this Ext.net

geoffrey.mcgill
Aug 03, 2010, 6:21 AM
Hi,

You'll need to install an SVN client tool which will handle connecting to the SVN server and getting the latest source code.

We use Tortoise SVN.

1. Download and install Tortoise SVN (http://tortoisesvn.net/downloads)
2. Create a new folder on your computer somewhere.
3. Right-click on the folder and select "SVN Checkout...". Follow the steps, but basically you'll be asked for the SVN url, then after it connects, your username and password.
4. Wait for everything to download. There's a lot in SVN, so this might take a while.
5. After download, double-click on the Visual Studio Solution file (.sln). After project has loaded in Visual Studio, Rebuild the Solution. This will compile new .dll's.
6. In you local web application/project, add a Reference to the new Ext.Net .dll (or Coolite.Ext.Web.dll in <v1.0).

Hope this helps.

geodan
Aug 04, 2010, 11:57 PM
Hey Geoffrey,

It turns out I already had Tortoise SVN installed, but updated anyway. However, I do not have any SVN Checkout context menu when I right click on my new folder...any ideas? Sorry bout this, seems noobish...just thought you might have some idea. I have the 32 bit version installed on my XP laptop.

Dan

Trying to uninstall/reinstall....people say it's a bug...it should work...

geodan
Aug 05, 2010, 3:21 AM
just had to uninstall it and reinstall it....it was an installer bug.

Digital.Dynamics
Apr 25, 2012, 11:47 AM
Hi

we tried to checkout and download the ext.net 2.0 project from the url : http://svn.ext.net/premium/branches/2.0/, but without success.

We are using TortoiseSVN 1.7.6 as svn client.

We had an error message from tortoiseSVN : unable to connect to a repository at URL...... could not read status line an existing connection was forcibly closed by the remote host.

Thanks

Daniil
Apr 25, 2012, 5:40 PM
Hi @Digital.Dynamics,

Welcome to Ext.NET!

Could you try again? I've just tried to checkout with success.

Digital.Dynamics
May 02, 2012, 2:07 PM
Thanks Daniil, but it still not working. Please which version of svn tools are you using?

Daniil
May 02, 2012, 2:15 PM
Hi,

I use TortoiseSVN 1.7.6, Build 22632 - 64 Bit.

Are you sure that you use the correct credentials and they are accepted?

Which moment are you facing this error?

unable to connect to a repository at URL......
could not read status line an existing connection was forcibly closed by the remote host.

Just after start? Or does it start to download files and the error occurs some time after?

Sometimes, I get an error similar the one you described after some time during downloading. Then I right click on the folder and choose "SVN Update". It continues to download the rest files.

Digital.Dynamics
May 02, 2012, 3:30 PM
Hi, Daniil

I tried many times but without success. I'm facing this error few minutes after clicking on button OK.

I never get the prompt for entering our credentials.

please help.

Vladimir
May 02, 2012, 4:33 PM
Try to open that link in the browser. What result do you have?

Digital.Dynamics
May 05, 2012, 2:51 PM
Hi,
I tried as you show me but still without success. The svn is showing fine in the browser.

With TortoiseSVN I had the following error :

Unable to connect to a repository at URL
'http://svn.ext.net/premium/tags/2.0.0DP1/Ext.Net'
OPTIONS of 'http://svn.ext.net/premium/tags/2.0.0DP1/Ext.Net': Could not read
status line: An established connection was aborted by the software in your
host machine.
(http://svn.ext.net)

This error is appearing after few minutes after trying the client SVN to connect the remote server.

Thanks.

Vladimir
May 05, 2012, 2:56 PM
Check firewall settings on your machine, may be it blocks svn client
Also, try on another computer

I checked recently, SVN server works correctly

Daniil
May 05, 2012, 10:28 PM
Unable to connect to a repository at URL
'http://svn.ext.net/premium/tags/2.0.0DP1/Ext.Net'


Well, DP1 is too old and should not be used.

You have said before that you are trying to checkout with this URL:
http://svn.ext.net/premium/branches/2.0/

There is the latest Ext.NET sources that you should get.

Do you have the same behavior with that URL?