PDA

View Full Version : Virtual Directory for SVN Coolite.Examples website



jchau
Nov 03, 2008, 1:17 PM
I am trying to set up a virtual directory in IIS to point to the Coolite.Examples website from SVN. I am getting the following error. I am able to run the website fiine from Visual Studio using VS's development server.



<title>Physical path can't be mapped to the current application.</title><style>
body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;}
p {font-family:"Verdana";font-weight:normal;color:black;margin-top: -5px}
b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px}
H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red }
H2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon }
pre {font-family:"Lucida Console";font-size: .9em}
.marker {font-weight: bold; color: black;text-decoration: none;}
.version {color: gray;}
.error {margin-bottom: 10px;}
.expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:hand; }
</style><h2>Physical path can't be mapped to the current application</h2>

geoffrey.mcgill
Nov 03, 2008, 1:23 PM
Hi jchau,

Which version of IIS are you running? Is the .NET 3.5 framework installed on that machine?


I'm investigating the error to see if I can narrow down the problem. 

jchau
Nov 03, 2008, 1:42 PM
I am running IIS 5.1 on Windows XP Professional. The virtual directory is set to ASP.NET version 2.0.50727 and .NET 3.5 is installed. I want to stress that I can run the website fine from Visual Studio so it's not a HUGE deal. I can always publish the website to inetpub\wwwroot.

Vladimir
Nov 03, 2008, 2:07 PM
Hi jchau,

I reproduced this error under XP (IIS 5.1). We will investigate this error.

But if you create separate site under IIS (it is impossible with standard tools but you can use http://www.jetstat.com/iisadmin/) then Examples Explorer will work properly under separate site

Timothy
Nov 12, 2008, 9:23 AM
What about us people with IIS7.0?

Cheers,
Timothy

geoffrey.mcgill
Nov 12, 2008, 9:26 AM
We're investigating this issue. 

Timothy
Nov 12, 2008, 9:29 AM
Thanks, and no rush, the Examples don't impact the overall product which has been running really nice as of late ;)

Cheers,
Timothy

geoffrey.mcgill
Nov 25, 2008, 6:38 PM
We committed some revisions to the example explorer today which should solve this virtual directory exception problem. 

If you get a chance, please svn update give it another go. Let us know if you run into any issues. 

jchau
Nov 25, 2008, 8:10 PM
Nice! Error is gone, and I can run the Examples website without loading the solution up
now. As for issues, a few icons are missing from the tree on the left,
and a few gridpanel examples are broken (not sure if that's due to
virtual directory or not). I have not tested all the examples yet, but
all the non-data related ones so far worked.





Missing icons:


http://m52f/cooliteexamples/icons/lightning-png/coolite.axd
http://m52f/cooliteexamples/icons/table_multiple-png/coolite.axd
http://m52f/cooliteexamples/icons/application_form-png/coolite.axd
http://m52f/cooliteexamples/icons/application_view_columns-png/coolite.axd
http://m52f/cooliteexamples/icons/layout-png/coolite.axd
http://m52f/cooliteexamples/icons/application-png/coolite.axd
http://m52f/cooliteexamples/icons/application_view_tile-png/coolite.axd
http://m52f/cooliteexamples/icons/application_view_detail-png/coolite.axd
http://m52f/cooliteexamples/icons/tab-png/coolite.axd
http://m52f/cooliteexamples/icons/wrench-png/coolite.axd
http://m52f/cooliteexamples/icons/application_double-png/coolite.axd

geoffrey.mcgill
Nov 25, 2008, 8:24 PM
Hi Jacky,

Can you try a browser hard-refresh (ctrl + shift + r ... and hold down for a couple moments) or maybe clear browser cache and reload Page. Let me know if that clears things up.


I'm also running a couple tests, but I did run into a caching issue earlier.

jchau
Nov 25, 2008, 8:37 PM
Tried Ctrl+F5, Ctrl+R and cleared IE8 browser cache. No go. Fiddler is showing the invalid icons are at



http://m52f/CooliteExamples/icons/layout-png/coolite.axd


And valid icons are at


http://m52f/CooliteExamples/resources/images/noimage.gif
http://m52f/CooliteExamples/extjs/resources/images/default/tree/folder-gif/coolite.axd
http://m52f/CooliteExamples/Examples/GridPanel/ArrayGrid/ArrayWithPaging/thumbnail.png


Just want to add that the missing icons are not a big deal at all. Just something I noticed.

geoffrey.mcgill
Nov 25, 2008, 8:45 PM
Perfect, thanks.

Part of the fix for the original exception was revising many of the relative paths. Looks like a couple were missed... although some of those icons paths should be autogenerated... hmmm.... [scratching head].

We'll fix this up and commit. I'll keep this thread updated with our progress.