PDA

View Full Version : Ext.NET 5.2.0 on .NET Framework 4.8



Peter.Treier
Oct 07, 2020, 1:09 PM
Hi,
we want to migrate all our projects using Ext.NET to Target Framework 4.8 (currently we are using 4.6.2).
I have read inside README.txt the system requirements below.

Is it finally Ext.NET.WebForms.5.2.0 compatible to Framework 4.8 ? Are there any know issues ?

Thanks in advance for your support.

## 1. System Requirements

1. Visual Studio 2015, 2017, 2019, or
2. Visual Studio Community 2015, 2017, 2019
3. .NET Framework 4.0, 4.5, 4.5.2 and 4.6

Regards,

geoffrey.mcgill
Oct 07, 2020, 6:51 PM
Hi @Peter.Treier,

Thanks for contacting us. We believe everything should work fine with .NET Framework 4.8, but we're running some tests to confirm.

We will also update the README and system requirements.

fabricio.murta
Oct 08, 2020, 4:31 AM
Hello @Peter.Treier!

I've been running test samples provided here in the forums using a project at .NET Framework 4.7.2 with no issues.

I just switched it to 4.8, and all seemed right on a quick check. This project is based on Ext.NET MVC -- so it supports both MVC and WebForms.

I also switched our Examples Explorer project (webforms-only), and all went smooth. I believe it is safe to switch your project and use Ext.NET. Although its native target is at 4.6, projects targetted at 4.7, 4.7.1, 4.7.2 and 4.8 can be linked to it without issues.

Let us know if you run into a problem and we'll fix it.

Hope this helps!

Peter.Treier
Oct 08, 2020, 8:11 AM
Thanks for your checks.

I will let you know in case of issues.