PDA

View Full Version : Ext.Net up-gradation from 2.5.2 to 5.2



Kartikeyp
Apr 24, 2020, 7:44 PM
Hi,

We are upgrading the Ext.Net 2.5.2 version to Ext.Net 5.2. After up-gradation we have lot of issues on EXT.Net library and also related to EXT JS issues.
We fixed the EXT.Net library issues but how to fix all the java script issues like showing error message add Events are deprecated.

Is any way to upgrade EXT.Net in short of time. As this is difficult to fix one by one issue manually?

Please revert us as soon as possible.

fabricio.murta
Apr 25, 2020, 5:12 PM
Hello @Kartikeyp, and welcome to Ext.NET forums!

I'm sorry to hear you are having hard times with the upgrade process.

Although in general the changes are minimal, the more you "customized" your 2.x Ext.NET product, the more likely it is to face breaking changes, especially when your product relied in undocumented or client-side code. This is mostly not a problem with server-side code, as you have plenty of "IntelliSense" and tools in your aid. But when it comes to client-side code, it goes way out of our control, as we usually try to keep breaking changes away between Ext JS versions, but they were introduced more than often thru versions 2.5.2 until 5.2.0.

So, unfortunately there's no "magic" way in fixing all Ext JS 4.x issues (from Ext.NET 2.x); the issues should be dealt with one by one, and each will take a different approach. I'd say for most, you'd just find the missing features were implemented to Ext JS and you will be able to rely on something that should be supported across further releases with less code and burden. But this is just a guess as we can't really tell how far your product went with customizations in the client-side code.

If you decide to go by the upgrade process, you can purchase a premium subscription with Ext.NET, and we will be here to help you as best as we can with Ext.NET upgrading issues.

Please bear in mind before making the decision some effort from your side is necessary for us to be able to provide you better support; notably being able to reduce the problems you find into runnable test cases; we suggest you to review our forums guidelines to help you decide on your choice.

Here are the relevant forum guidelines that "helps us help you" in times of need, we really recommend you to take your time to review them as this allows the best support experience in the upgrade process.

- Tips for creating simplified code samples (http://forums.ext.net/showthread.php?61176-Tips-for-creating-simplified-code-samples)
- More Information Required (http://forums.ext.net/showthread.php?10205-More-Information-Required)
- Forum Guidelines (http://forums.ext.net/showthread.php?3440-Forum-Guidelines-For-Posting-New-Topics)

Hope this helps!

Kartikeyp
Apr 29, 2020, 1:25 PM
I am facing issue regarding addEvents deprecated in 7.2 Ext Js.
How to fix it as there are no any documents that tell us inplace of this funcion what we used?
Please suggest us as it is too time consuming process.