PDA

View Full Version : problem in Ext.Net installation



ghada
May 05, 2017, 3:01 PM
hello every body

I have a problem of installing Ext.Net on visual studio 2015, when the installation complete then i have Ext.NET.Default.aspx page which is found after ext.net package installation complete, so when i want to run this page i find a browser message "HTTP Error 404.0 - Not Found" so what the solution of this problem??

Ext.NET.Default.aspx code:


<%@ Page Language="C#" %>

<script runat="server">
protected void Button1_Click(object sender, DirectEventArgs e)
{
X.Msg.Notify(new NotificationConfig {
Icon = Icon.Accept,
Title = "Working",
Html = this.TextArea1.Text
}).Show();
}
</script>

<!DOCTYPE html>

<html>
<head runat="server">
<title>Ext.NET Example</title>

<link type="text/css" rel="stylesheet" href="http://speed.ext.net/www/intro/css/main.css" />
</head>
<body>
<ext:ResourceManager runat="server" Theme="Triton" />

<header>
<a href="http://ext.net/"><img src="http://speed.ext.net/identity/extnet-logo-large.png" class="logo"/></a>
</header>

<div class="wrapper">
<h1>Welcome to Ext.NET!</h1>
<p>Thank you for installing Ext.NET.</p>
<p class="last">You can check that everything is working correctly by submitting a value in the message box below.</p>
</div>

<form runat="server">
<ext:Panel
ID="Window1"
runat="server"
Title="Welcome to Ext.NET"
Height="215"
Width="350"
Frame="true"
Collapsible="true"
Cls="box"
BodyPadding="5"
DefaultButton="0"
Layout="AnchorLayout"
DefaultAnchor="100%">
<Items>
<ext:TextArea
ID="TextArea1"
runat="server"
EmptyText=">> Enter a Test Message Here <<"
FieldLabel="Message"
Height="85"
/>
</Items>
<Buttons>
<ext:Button
ID="Button1"
runat="server"
Text="Submit"
Icon="Accept"
OnDirectClick="Button1_Click"
/>
</Buttons>
</ext:Panel>
</form>

<div class="wrapper wrapper-lower">
<h2><a href="http://ext.net/support/">Technical Support</a></h2>
<p>Need a little help? Visit our <a href="http://ext.net/support/">Support</a> page for links to documentation, examples and more. </p>
<hr>
<h2><a href="http://forums.ext.net/">Community Forums</a></h2>
<p>Keep up to date with all things Ext.NET by joining the active community in our <a href="http://forums.ext.net/">Forums</a>.</p>
<hr>
<h2><a href="http://examples.ext.net/">Examples</a></h2>
<p>Ext.NET features 100+ Components and 750+ Samples for use in your ASP.NET apps. Check out the <a href="http://examples.ext.net/">Examples Explorer</a> to see what's possible.</p>
<hr>
<h2><a href="http://ext.net/store/">Purchase</a></h2>
<p class="last">When you're ready, <a href="http://ext.net/store/">purchase</a> a license and start building web apps with ease!</p>
</div>

<footer>
<p class="last">&copy; 2008-<%= DateTime.Today.Year %> <a href="http://object.net/">Object.NET</a>, Inc. All Rights Reserved.</p>
</footer>
</body>
</html>

fabricio.murta
May 06, 2017, 1:06 AM
Hello @ghada, and welcome to Ext.NET forums!

Did you install your project out of the WebForms template, right?.. That one which comes with a sample page when you create and run.

That project template enables an incompatible feature called FriendlyUrls, which strips the .aspx extension from the pages visited and turns Ext.NET pages inaccessible.

To fix that, just open App_start/RouteConfig.cs and disable the first three lines in RegisterRoutes():



var settings = new FriendlyUrlSettings();
settings.AutoRedirectMode = RedirectMode.Permanent;
routes.EnableFriendlyUrls(settings);


Another problem can happen if you added MVC bindings and did not install the Ext.NET.MVC NuGet package. You won't be able to open pages as it will respond with 404 for each resources fetch attemp. You are not supposed to use the Ext.NET NuGet package (without MVC in the name) in MVC projects (use the Ext.NET.MVC, Ext.NET.MVC4 or Ext.NET.MVC5 -- the first is MVC5 as well). But if you happen to have a project with some MVC views and all Ext.NET related pages in a WebForms folder (which may just happen to be true), all you have to do is add a line in the same RouteConfig.cs file:



routes.IgnoreRoute("{exclude}/{extnet}/ext.axd");


This template for WebForms project also adds yet other problems with code that is not compatible with Ext.NET, so watch out while using it, for there should be dragons ahead! One of those additional problems is if you use the template's master page as an Ext.NET page's master.

The problem is that we can't guarantee what project templates do and do not do so, before starting off a fresh Ext.NET project, when you choose the project settings, you may check below to add both WebForms and MVC bindings, but don't choose a full WebForms nor MVC template, they will only bring trouble to you while using Ext.NET.

In the figure below the green arrows point to acceptable choices and red arrows point to choices that ought to bring you trouble while creating a new project:
24935

In short, avoid project templates, but don't mind the bindings of either MVC or Webforms according to your project technology goals. But if you do MVC bindings to your project, do install the Ext.NET.MVC NuGet package.

I hope this helps! And suggest you try again Ext.NET from a blank project template.

ghada
May 06, 2017, 5:52 AM
thank you very much, the problem are solved when removing the three lines in the routeConfig file