View Full Version : [CLOSED] [#1371] [4.1.0] Grid - Row editor - Field-editors are not showing.

Aug 14, 2016, 1:16 PM
When double-tapping on a row the row-editor shows up, but there are no editors for the showing, so it is impossible to edit the row.

var x = Html.X();
var data = new List<object>{
Name = "Lisa"

Name = "Bart"

.Data( data )

Aug 15, 2016, 8:43 PM
Hello @sveins12!

Thank you very much for all the feedback on Ext.NET Mobile! We're very excited to go thru all your reports!..

In this case it seems all that's missing is to set the column as editable. Check it out by adding .Editable(true) to the column definition! Let us know if it didn't help at all.

EDIT: before I forget, this is how the Editable GridPanel example (http://mobile.ext.net/#demo/editablegrid) in our mobile examples explorer (http://mobile.ext.net/) is written and it works. Of course I tried with your example and it also displayed the editor field in the edit dialog.

Aug 15, 2016, 9:18 PM
It works, thank you!

By the way, in the other Ext.NET versions the column is implicitly set to editable if it has an editor defined. Maybe this should be something to consider for the Mobile-edition.

Aug 16, 2016, 5:31 AM
Hello! Of course, we've just logged the feature request under #1371 (https://github.com/extnet/Ext.NET/issues/1371). This is a great time to decide on such a behavior as it would get harder to change defaults after the final version is out.

Thanks for all the feedback!

Aug 16, 2016, 4:12 PM

The change has been committed to GitHub. Now setting a Column's Editor is enough to get the Column editable.

Thank you for raising it.