PDA

View Full Version : [CLOSED] Mandatory fields expand when not filled correctly



Peter.Treier
Aug 05, 2016, 3:20 PM
Hello,

I have a problem with mandatory fields only in IE...

Here is a screenshot explaining the problem:

24703

You can clearly see the behaviour.
This was tested using ExtNet 4.1. In the other browser, this doesn't happen because the icon is not shown.

What is causing the problem?

Thanks in advance.

fabricio.murta
Aug 06, 2016, 6:13 AM
Hello Peter!

This is because of the hidden exclamation mark icon that is shown from a hidden div/span when the validation fails. Perhaps you want to either reserve the space or maybe suppress showing the additional icons to the validation failure?

Peter.Treier
Aug 08, 2016, 8:47 AM
Hello Fabricio,

I guess you are right.
You were talking about to suppress showing the icon when the validation fails, how can I do that?

Thanks in advance for your answer!

fabricio.murta
Aug 08, 2016, 7:27 PM
Hello! Suppressing the icon output during validation is a matter of using MsgTarget="None".

You may also want to investigate in the layout you are using how you could reserve the icon space, leaving a blank space where the icon just shows up without having to resize the fields. It will most likely to choose the right layout and possibly (I did not investigate it, in fact) set a fixed width/height/hidden state to the validation message target box.

Hope this helps!

Peter.Treier
Aug 09, 2016, 8:34 AM
It worked perfectly!
That's exactly what I wanted to achieve :)

Thanks a lot!

fabricio.murta
Aug 09, 2016, 6:41 PM
Okay Peter, glad we could be of help! Thanks for the feedback, we really do appreciate it! We will be marking this thread as 'closed', then.