PDA

View Full Version : ASP.NET 5 and WebForms



Zdenek
Nov 30, 2015, 11:01 AM
Hello
I checked both threads about the topic here and I got understanding that you plan to support MVC 6
It might be bit difficult task and will take you some time (once final version of aspnet 5 is out) but your plan is to do the best to make it work

Now - what about ext.net webforms?
As far as i understand asp.net 5 does not have webforms.
BUT I'm thinking how much of webform technology you are actually using.
So is there anything that would break Ext.NET webform version to work?
(possibly there could be something - but will it stop you from building - even limited - ext.net webform version?)
Any idea or note welcome, if too early stage feel free to ignore this question

Thanks
Zdenek

geoffrey.mcgill
Dec 09, 2015, 5:44 PM
Our current goal is to release Ext.NET 4 with support for all versions of ASP.NET 4 WebForms and MVC.

After Ext.NET 4 has been released, we will investigate transitioning Ext.NET 4 MVC to ASP.NET 5 MVC 6.

WebForms support is not included by Microsoft in ASP.NET 5, so at this moment, it appears we will not be able to upgrade Ext.NET WebForms to ASP.NET 5.

Developers will still be able to able to create new Ext.NET WebForms projects in ASP.NET 4, and we will continue to support for a long time.

Hope this helps.

Daniil
Dec 10, 2015, 1:40 PM
Just for references:
ASP.NET 5 support (https://github.com/extnet/Ext.NET/issues/620) GitHub issue
MVC 6 support (https://github.com/extnet/Ext.NET/issues/855) GitHub issue

Zdenek
Dec 10, 2015, 1:57 PM
Ok
Thanks for info