PDA

View Full Version : [CLOSED] I need urgent help with TabPanel appearance issue



Ariel
Sep 24, 2015, 12:52 AM
Hi, I have an important demo of our software on Friday and I need your urgent help to get rid of an ugly UI problem (ext.net version 2.5.2).

I have two problems:

1) I'm using MarginSpec on TabConfig in order to move tabs a bit down so that I have enough space for the badges. See picture below.

The problem is that there is a line which doesn't move down (I marked it in the picture below). I tried many things and couldn't get it to go away or move down.
24245

TabPanel -



<ext:TabPanel ID="ScreenerTabs" runat="server" AnchorHorizontal="100%" ActiveIndex="0" Border="false" header="false" plain="true" DeferredRender="true" LayoutOnTabChange="true" MarginSpec="0 10 0 10" Layout="AnchorLayout">
<Defaults>
<ext:Parameter Name="labelWidth" Value="150" Mode="Raw" />
<ext:Parameter Name="margin" Value="10 15 0 0" Mode="Value" />
</Defaults>


TabConfig -



<TabConfig runat="server" MarginSpec="10 15 0 0" Width="85">
<Plugins>
<ext:Badge id="bdgTabOrigRating" IDMode="Explicit" runat="server" UI="Primary" Scale="Small" Text=" " Visible="true" RenderToBody="false" HideEmpty="true" />
</Plugins>
</TabConfig>


The second problem -

2) The second problem is that I want badges to not show when value is empty, I tried so many things. Badge disappears and won't show at all when value is an empty string. I tried using HideEmpty="true". I tried using Visible. It doesn't work.

Please send me an answer first thing tomorrow morning please.

Daniil
Sep 24, 2015, 7:01 AM
Hello @Ariel,


The problem is that there is a line which doesn't move down (I marked it in the picture below).

I could not reproduce it. Please post a full test case to copy, paste and run.



2) The second problem is that I want badges to not show when value is empty, I tried so many things. Badge disappears and won't show at all when value is an empty string. I tried using HideEmpty="true". I tried using Visible. It doesn't work.


At first attempts I could not reproduce it either. Anyways, it is an individual issue. Please start a new forum thread with a test case to reproduce.


Please send me an answer first thing tomorrow morning please.

Please post standalone test cases in such situations. It is the best chance to get a solution in time. Currently, I am trying to reproduce it rather investigating a solution. I will continue looking how to reproduce it, but it would be best if you provide samples to reproduce and I will start investigating right away.

Daniil
Sep 24, 2015, 2:56 PM
We could not reproduce the issues so far. So, we'll wait test case from you.