PDA

View Full Version : [CLOSED] FileUploadField is not working



VSPL
Jan 09, 2015, 3:55 AM
Hello, in my web-form application the "FileUploadField" control is not showing the file-open dialog on few initial clicks (general first 3 clicks) but then it shows the dialog after I have used some features of the form like click on some other buttons which invokes some direct events, I cannot post the source because this is happening in all pages. I have tested this on different computer also browser I have targeted is Google Chrome.

Further, In my application I have override the WebPage "SavePageStateToPersistenceMedium" method just to disable the view-state, since I don't want any view-state to be generated.

Daniil
Jan 09, 2015, 11:32 AM
Hi @VSPL,

Welcome to the Ext.NET forums!


I cannot post the source because this is happening in all pages.

Yes, we don't need all the pages, but we need a test case to reproduce it.

FileUploadFields in this example appears to be working.
http://examples2.ext.net/#/Form/FileUploadField/Basic

VSPL
Jan 10, 2015, 3:46 AM
Hello, Thanks for the reply, we've found the issue it was with below CSS in our code:



input.x-form-file-input
{
width:100%;
margin: 0 auto;
}


If we remove this CSS, then the file upload control works properly for every click. In past I've placed this CSS when I've a form with some file upload controls and lots of buttons together in panel or toolbar there was some issue which I exactly don't remember the case right now, I will revert to you back in future if I require further support. Thanks