PDA

View Full Version : Can't Install Ext.Net 3.0



keeper
Jan 05, 2015, 3:34 PM
I can?t install ext.net 3.0 MVC Packaged neither from nuget or manual install, it gave me Invalid Operation Exception on Visual Studio 2012 and Windows 7.

Dimitris
Jan 05, 2015, 3:47 PM
Can you please write the steps you are following?

Vladimir
Jan 05, 2015, 3:56 PM
Hi

Ext.Net.MVC is compiled for MVC 5 and .NET 4.5

Do you Update 4 for VS 2012? I mean applied Update 4.
Also you might need to install ASP.NET and Web Tools 2013.1 for Visual Studio 2012.
See http://stackoverflow.com/questions/19102831/how-to-install-asp-net-mvc-5-in-visual-studio-2012

keeper
Jan 05, 2015, 3:59 PM
Start new empty MVC4 Project in VS 2012 -> Project -> Manage NuGet Packages... -> Search for Ext.Net 3 -> Click Install

This is the install log:

Attempting to resolve dependency 'Ext.NET.Utilities (≥ 2.5.0)'.
Attempting to resolve dependency 'Transformer.NET (≥ 2.1.1)'.
Attempting to resolve dependency 'Newtonsoft.Json (≥ 6.0.6)'.
Attempting to resolve dependency 'WebActivatorEx (≥ 2.0.3)'.
Attempting to resolve dependency 'Microsoft.Web.Infrastructure (≥ 1.0.0.0)'.
Installing 'Ext.NET.MVC 3.0.0'.
Successfully installed 'Ext.NET.MVC 3.0.0'.
Adding 'Ext.NET.MVC 3.0.0' to Web.
Uninstalling 'Ext.NET.MVC 3.0.0'.
Successfully uninstalled 'Ext.NET.MVC 3.0.0'.
Install failed. Rolling back...
Failed to add reference to 'Ext.Net'.

Vladimir
Jan 05, 2015, 4:04 PM
You have to use MVC 5 project with Ext.NET.MVC

keeper
Jan 05, 2015, 4:16 PM
Thanks for the answers, what NuGet package do i install for MVC4 ?

Dimitris
Jan 05, 2015, 4:21 PM
Here is what I did:

http://forums.ext.net/showthread.php?47841-dont-working-installation-MVC-in-visual-studio-2013&p=226201&viewfull=1#post226201

In my steps I am installing 2.5.3 but it works with 3 too.

keeper
Jan 05, 2015, 5:11 PM
Hi Mimisss

I follow the steps for MVC4 and MVC5 started from empty project and have the error:

Install failed. Rolling back...
Install-Package : Failed to add reference to 'Ext.Net'.
At line:1 char:16
+ install-package <<<< ext.net.mvc
+ CategoryInfo : NotSpecified: (:) [Install-Package], InvalidOperationException
+ FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Com mands.InstallPackageCommand

Dimitris
Jan 05, 2015, 5:28 PM
Can you install any nuget package at all? (I mean, except for ext.net)

I googled a bit (e.g. http://stackoverflow.com/questions/8314400/nuget-add-reference-error-while-installing-packages) and it seems to be a problem with nuget in general and not with ext.net in particular.

Please, try installing another package and let us know.

keeper
Jan 05, 2015, 5:57 PM
Other packages work. I'll try other options

Vladimir
Jan 05, 2015, 6:30 PM
Just try to remove default MVC references from your project, install latest stable from Nuget (MVC4 or 5), after that install Ext.Net from Nuget
See http://forums.ext.net/showthread.php?46401-CLOSED-Ext-Net-references-System-Web-Mvc-4-0-0-1&p=210242&viewfull=1#post210242


https://www.nuget.org/packages/Microsoft.AspNet.Mvc/5.2.2
https://www.nuget.org/packages/Microsoft.AspNet.Mvc/4.0.4

keeper
Jan 05, 2015, 7:06 PM
it appears to be a VS2012 error, i'll try to re-install later, thanks for your help.

geoffrey.mcgill
Jan 05, 2015, 7:53 PM
Later today we're going to release an Ext.NET 3.0.0.1 package to NuGet which should automatically fix these MVC installation issues.

keeper
Jan 05, 2015, 8:09 PM
Thanks very much for your support, wait for the new package & try it