PDA

View Full Version : [CLOSED] Enter key in TextField does page postback



reinout.mechant@imprss.be
Nov 08, 2014, 8:38 PM
Hello,

I just upgraded my solution to 2.5.3.31229 coming from 2.5.2.10697.

Everything remained the same, but now every enter hit in a textfield (even the ones that don't have EnableKeyEvents) result in a page postback.
Somehow your disabling of the page postback doesn't work anymore.

Is that normal?

Kind regards,

Reno
PS: I have a paying subscription, why can't I post anymore in the Premium thread?

reinout.mechant@imprss.be
Nov 09, 2014, 8:00 PM
I forgot to mention that I got that latest version via Nuget.

Daniil
Nov 10, 2014, 2:01 PM
Hi @reno,


PS: I have a paying subscription, why can't I post anymore in the Premium thread?

Maybe, the subscription is expired? I will let Geoffrey know about this problem.

reinout.mechant@imprss.be
Nov 11, 2014, 11:33 AM
Thanks Daniil,

Is there already an idea on the issue itself?

Kind regards,

Reno

Daniil
Nov 11, 2014, 12:30 PM
No, I don't quite have any idea what might cause such the change in behavior.

reinout.mechant@imprss.be
Nov 11, 2014, 8:08 PM
In the sense of you don't experience this issue with that version, or in the sense of you do, but you don't know what causes it?

In our case, running it both in Chrome or Internet Explorer gives the same behaviour, so it is regardless the version of browser.

Daniil
Nov 11, 2014, 8:16 PM
I have experienced such an issue, but only if there is a single field on the page. In this case it is how the browser behaves.

I guess you have more than one field on the page, don't you?

Vladimir
Nov 11, 2014, 8:19 PM
Is TextField single field in the Page?

If yes then it is expected behaviour for browsers
This behaviour was introduced in the HTML 2.0 specification.
http://www.alanflavell.org.uk/www/formquestion.html



When there is only one single-line text input field in a form, the user agent should accept Enter in that field as a request to submit the form

http://www.w3.org/MarkUp/html-spec/html-spec_8.html#SEC8.2

reinout.mechant@imprss.be
Nov 11, 2014, 8:34 PM
It is indeed a single input field, but I never noticed this behaviour before.

Thanks,

Reno

geoffrey.mcgill
Nov 12, 2014, 1:42 AM
Hello Reno,

It appears your Premium Support subscription expired on 2014-05-02 and was not renewed.

If you would like to purchase a new Premium Support subscription, please feel free to contact support@object.net and we'll send back a store link for checkout.

Hope this helps answer your questions.

reinout.mechant@imprss.be
Nov 12, 2014, 8:29 AM
Hi Geoffrey,

I must have missed that, I just sent the email to support.
Thanks for the feedback.

Kind regards,

Reno

Daniil
Nov 13, 2014, 7:56 AM
Welcome back to premiums!

Please clarify do you need any assistance more in this thread?

reinout.mechant@imprss.be
Nov 13, 2014, 5:10 PM
Hello Daniil,

No thanks, it kind of resolved itself, not sure how though...

Kind regards,

Reno