PDA

View Full Version : [CLOSED] FieldContainer not render combobox and button



jesperhp
May 13, 2014, 2:34 PM
<ext:Window runat="server" ID="window_Request_Detail" Width="800px" Layout="Form"
AutoScroll="true" Title="AddNewRequestDetail"
Height="690px" Modal="true" Closable="true" CloseAction="Hide" Resizable="false"
Shadow="false" Maximizable="true">

<Items>
<ext:TabPanel ID="tbpanelHelpDeskInfo" runat="server">
<Items>
<ext:FormPanel ID="frmpnl_RequestInfo" Padding="10" Width="400px" runat="server"
AutoScroll="false" MonitorValid="true" Title="TitleRequestInfo "
StyleSpec="padding-bottom:20px;" BodyStyle="background-color:#dfe8f6">
<Content>
<ext:Container ID="container23" runat="server">
<Items>
<ext:Container ID="ContainerMain" Layout="Column" runat="server" Height="30px">
<Items>
</Items>
</ext:Container>
</Items>
</ext:Container>
<ext:Container ID="Container2" Layout="Column" Height="205px" runat="server">
<Items>
<ext:Container ID="Container3" ColumnWidth="0.5" StyleSpec="padding-right:5px" runat="server">
</ext:Container>

<ext:FieldContainer Layout="HBoxLayout" runat="server" FieldLabel=" User">
<Items>
<ext:ComboBox ID="cmb_Request_User" runat="server" Html="sdsdasd" DisplayField="User_Name"
ValueField="Id" Editable="true" EmptyText="Select User" Width="219px" AllowBlank="true"
Selectable="true" TypeAhead="false" LoadingText="Searching..." HideTrigger="true" Margins="0 3 0 0"
MinChars="1">
<Listeners>

</Listeners>
</ext:ComboBox>
<ext:Toolbar ID="Toolbar1" runat="server" Flat="true">
<Items>
<ext:Button ID="Button1" runat="server" Icon="Report" ToolTip="ToolTipRequestDetailUserRequests">
<Listeners>
<Click Handler="

" />
</Listeners>
</ext:Button>
</Items>
</ext:Toolbar>
</Items>
</ext:FieldContainer>
</Items>
</ext:Container>
</Items>
</ext:Container>
</Content>
</Items>
</ext:TabPanel>
</Items>
</ext:Window>


Here I am using FieldContainer which have field label and combo box and button but unfortunately controls not render and show combobox and button
The layout that looks fine
Layout A
http://forums.ext.net/attachment.php?attachmentid=10911&stc=1
now the layout missing controls
Layout B
http://forums.ext.net/attachment.php?attachmentid=10901&stc=1

Layout A taken from v1.1 and its render control proper and also show combobox and button as well
but Layout B taken from v2.x and its miss the control of comboxbox and button

Thank

Daniil
May 13, 2014, 4:03 PM
Hi @jesperhp,

I tried your piece of code and the ComboBox and the Button appears to be rendered for me.

So, it is hard to say why it is not rendered for you. Though, please try to set some Height for the FieldContainer, like Height="22".

jesperhp
May 14, 2014, 1:43 PM
Hi @jesperhp,

I tried your piece of code and the ComboBox and the Button appears to be rendered for me.

So, it is hard to say why it is not rendered for you. Though, please try to set some Height for the FieldContainer, like Height="22".

Hi

When I set height for FieldContainer its takes more space height wise but ComboBox and Button does not appear for me

Thanks
http://forums.ext.net/attachment.php?attachmentid=11031&stc=1

Daniil
May 14, 2014, 1:55 PM
Please try Width="300" for the FieldContainer.

Yes, it is a guesswork. I am not sure about the things without a test case to reproduce it.

jesperhp
May 14, 2014, 1:58 PM
Please try Width="300" for the FieldContainer.

Yes, it is a guesswork. I am not sure about the things without a test case to reproduce it.

HI

I have changed Layout="Column" to Layout="ColumnLayout" and now its working


Thanks

Please mark it close