PDA

View Full Version : Free minor version upgrades



bright
May 12, 2014, 12:53 PM
Hello,

if I purchase an ext.net pro license it says that minor version upgrades are included. What does that mean exactly?
Is 2.5 --> 2.6 included or only 2.5.0 --> 2.5.1?

Thanks in advance,
bright

Daniil
May 12, 2014, 1:24 PM
Hi @bright,

Only the first version number means major, the rest is minor. So, you will be free to update 2.5 => 2.6 => 2.x.x.

bright
May 12, 2014, 1:35 PM
Thanks, that sounds good.
Do you have a roadmap when the 3.0 Version will be released?
Or asked differently: is it worth waiting for the next major release if we plan to start building a new intranet application in about 3 to 4 months?
Thank you,
bright

geoffrey.mcgill
May 12, 2014, 1:35 PM
See http://semver.org/

[MAJORVERSION].[MINORVERSION].[PATCH]

geoffrey.mcgill
May 12, 2014, 1:38 PM
Thanks, that sounds good.
Do you have a roadmap when the 3.0 Version will be released?
Or asked differently: is it worth waiting for the next major release if we plan to start building a new intranet application in about 3 to 4 months?
Thank you,
bright

Related posts:

http://forums.ext.net/showthread.php?31901-ExtJS-5-0-Beta-and-the-Crisp-Theme

http://forums.ext.net/showthread.php?27212-Ext-Net-3-0&p=143901&viewfull=1#post143901

Hope this helps.

bright
May 12, 2014, 1:51 PM
Thanks for this information, that does indeed help.

Can you already tell if there will be many major api breaks from ext.net mvc 2.5.0 (razor views) to 3.0?

Thanks,
bright

Daniil
May 14, 2014, 5:13 AM
The goal is to have as little breaking changes as possible and make migrating from v2 to v3 pretty straightforward. We will see how we cope with that:)

Though, we depend on ExtJS 5 here. So, there will be some major breaking changes. For example, no IE6 and IE7 support. Also, there will be a big change in the Charts package. The old one will be probably discontinued and replaced with a new one. Probably, a lot of API changes in Charts are coming.

Also we are considering dropping of .NET 3.5 and MVC 3 support.
http://forums.ext.net/showthread.php?29311